Autosave during commands


#1

Guys, why do you tell us autosave runs unnoticed and not during a command? In my case it does all the time.

Even when not working on a file on the server but local it every 3-5 min. starts right during a command or while moving around. It takes just 10-15 seconds, but that’s annoying enough.
Please, fix that or give an explanation!
Thanks a lot


(Marlin Prowell) #2

Autosave does not run when a command is active. If it did, it could potentially write a corrupt 3DM file because your model might be in an inconsistent state. Try this:

  1. Create a new model with a few objects, save it to your Desktop, and close the model.
  2. Open the model again, making sure you can also see the preview of the model on your Desktop.
  3. Add a few more objects.
  4. Start the Rectangle command and click to establish the first rectangle corner.
  5. Do not complete the Rectangle command. Wait as long as you would like.
  6. The model preview never changes, indicating an Autosave has not occurred. The model file date never updates, indicating an Autosave has not occurred.
  7. Finish the Rectangle command by clicking the location of the second corner.
  8. Wait without touching the mouse. Sometime within the next 20 seconds the model preview will change, indicating an Autosave finally occurred.

Autosave does not run when you are manipulating your model. Try this:

  1. Create a new model with a few objects, save it to your Desktop, and close the model.
  2. Open the model again, making sure you can also see the preview of the model on your Desktop.
  3. Add a few more objects.
  4. Rotate your model or pan your model with the right mouse button. Click in different viewports to change the active view. Click on objects to select them. Keep doing these kinds of things frequently for as long as you would like.
  5. The model preview on your Desktop never changes, indicating an Autosave has not occurred. The model file date never updates, indicating an Autosave has not occurred. As long as you are actively manipulating the model, an Autosave does not occur.
  6. Stop manipulating the model and wait without touching the mouse. Sometime within the next 20 seconds the model preview will change, indicating an Autosave finally occurred.

I tried duplicating this by putting a 300 MB model on a USB thumb drive. I did this to stress the autosaving software. Autosaves happen in two phases. First, the model is written to an in-memory buffer, and then that buffer is written to disk. The user interface is supposed to be unlocked after the model is written to memory. I found that, although the user interface was not locked, the viewports would not update until the file had been written to the disk. This will be fixed in the next WIP release so the viewports update after the memory buffer is created. This change will affect UI responsiveness when writing to slow network drives, but will have marginal, if any, effect when writing to a local drive.

I’ve asked before, and I’ll ask again. I would like you to post a copy of your OpenGL settings so we can see what kind of hardware and software you are running.

I also cannot duplicate file saves that take 5-15 seconds on a local drive. I ask again that you either post or send to us a model that exhibits this behavior so we can see what the issue is. See the Reporting Problems post at the top of the Rhino for Mac forum for information about sending a file to us.

To be able to help, we need to get enough information from you so we can see your problem.