Automatically resume cycles rendering after a 'render'

Every time I do a “Render” Cycles pauses and I have to manually turn it back on. Is there a setting somewhere to fix that? Why is that the default behavior?

There is no setting for that.

It is the ‘default’ behavior probably through oversight.

RH-82060 Raytraced stays paused after _Render

would that not be the ideal setting anyway, since a background render in the viewport just slows down the render?

or am i misunderstanding that.

Pausing while rendering is expected. Once a render is complete active Raytraced viewports should continue.

1 Like

i am not quite awake it seems. that was a dumb questions :frowning:
but who would want to finish a render in the viewport when the render is finished? that could be optional then but maybe a good standard setting after all.

There’s no reason to have to hit a weird button to get a Raytraced viewport working again just because it paused itself to do a render. I’ve been using GPU rendering since before GPU rendering was a thing(the Caustic cards some Rhino users got for promotional purposes back in the 10s) and never had to do that lol.

Thing is that being paused also means non of the subsequent updates work, including viewport manipulation.

i would never want that render to proceed, i see this as a test render and render the real deal in the render window.

1 Like

ic. that makes sense then and completely turn this around… sorry i did not notice that on mac.