Auto register plug-in built with rhino common

I want to update rhino application automatically with a plug-in right after the installation.

Can plug in build with rhino common be used with Rhino Installer engine?

I also tried unsuccessfully to add proper registry entry for the plug in using reg file.



Sure - RHI files are just ZIP files.

When trying to install the plug-in I am getting “…package is not compatible with the Rhino Installer Engine”. I tried different things from including just plug in file in the archive to creating a directory structure with rhino 5.0/x64. I am not sure how to track down the problem. Do you have any suggestions what might be wrong?

Try adding the following to your AssemblyInfo.cs file:

[assembly: AssemblyInformationalVersion("2")]


Thanks again for your reply.

I tried your suggestion before but it but the compatibility error was still

I also overwrote calls to Plugin.Id and Plugin.Name properties based on the
info from your wiki that was intended for the legacy Rhino_DotNet just to
check if that might work.

I just wonder if plug-in build with rhino common can be used with the Rhino
installer since on your wiki there is a note:

“This information pertains to plug-ins built with the legacy Rhino_DotNet
SDK. This informationdoes not apply to plug-ins built with RhinoCommon.”

One thing that I just noticed that my plug-in is type of DigitizerPlugIn.
Would it make any difference?

Is there anything else I migh missed?


You don’t need to do this for RhinoCommon plug-ins.

Just run out of options. It is a black box. Why just making the registry
entry does not do the trick? Are you using some additional configuration? I
am not sure what else I can try.

@rajaa and @will have looked at the Rhino Installer Engine code lately and may be able to help

Hey Jacek,

I just ran the RhinoCommon plug-in wizard, build the project, and zipped the output using WinZip. The Rhino installer engine ran the .RHI without any issue our with out any modifications to the project. I’m running Rhino 5 SR11.

With that, what version of Rhino are you testing against. What are you zipping with?

– Dale


I will get back to you next week and I will send you all the information
and the files. It definitely might be the configuration issue. Thanks for
looking into it.



I also was able to create a simple plug in and install it no problem.
However, for some reason the one that we have for our Rhino PureWeb version
fails to install with the engine. I tried a few things today, and checked
the program but I could not find anything suspicious. I am attaching rhi
file with our plug in. It was compressed with winzip. Maybe you can debug
it inside the installer.

Having said that, I just want to install our plug in without user
interaction. I am not sure if your installer will allow that so maybe even
finding what the problem is will still not be able to do what we want.

Can you check why just recreating windows registry entry does not
automatically makes Rhino recognize and load the plug in properly?

Thanks again for checking into it. Please let me know if there is anything
else I can try or if you need anything. I appreciate your help.