Auto-Raise

A first time poster here, so be gentle…

I have a dual monitor set up and run several instances of Rhino at once. With many applications overlapping, it is useful to activate a window by just hovering over it. However auto-raising the window is not desired. There are settings in windows itself (which I have made) but they have no effect on Rhino (or grasshopper for that matter).

So does anyone know how to disable the autoraise?

Hi @customgamebits,

By “auto-raise”, do you mean “bring application window to the foreground”?

– Dale

Dale,

Thanks for responding.

Windows offers two ways to grant focus and focus allows you to interact with the application. Either you click the window or just mouse over it. Which way it works is set by preferences in windows.

In addition, when a window becomes active, the operating system can sometimes bring the whole window to be on top of all the other windows. Often this referred to auto-raise. Windows has a setting to delay this but some applications ignore this setting.

I was hoping there was a setting in Rhino & grasshopper that would prevent the auto-raise action.

Note this is mainly a problem when a grasshopper window is open

Hi @customgamebits,

Rhino does not have a setting that controls this.

– Dale

Ok. That confirms my research. Is there a process for making feature requests?

you are doing it now! :wink: