Atom and Git issue

Hi Mac’ers

After installing Atom editor on my EMAC (10.8.5 lion), it returns this message after attempting to install the Rhino-Python package.

Failed to install rhino-python because Git was not found.
The rhino-python package has module dependencies that cannot be installed without Git.
You need to install Git and add it to your path environment variable in order to install this package.
Run apm -v after installing Git to see what version has been detected.

apm 1.6.0
npm 2.13.3
node 0.10.40
python 2.7.2
git 2.7.1

Git git version 2.7.1 installed
checked Git – version path /usr/local/bin/git
checked echo $PATH on my IMAC /usr/local/bin/git:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin

Not sure what the problem is with the PATH / or missing any variable because I’m new to MAC computers ?

Can someone describe a simple and clear procedure to get atom linked to GIt so that the Rhino-Python package can be installed.

Any help would be grandly appreciated.

Not sure what the problem is. The latest version of Atom supports osx 10.8 so that shouldn’t be your problem. Have you tried installing the package via apm?

apm install rhino-python --verbose

Dear Alain.
No, I followed the standard procedure.
Atom install package for mac
Git Install Package
Then I tried to install rhino-Python via Atom which returned the error message.

I just tried to install the package with your input and I received a similar error message.

The log in terminal is quite long and I’m not skilled enough to interpret the errors displayed.
First error _
npm WARN addRemoteGit git+ resetting remote /Users/rodolfosantos/.atom/.apm/_git-remotes/https-git-github-com-yyx990803-vue-git-2062c581 because of error: { [Error: Command failed: ] killed: false, code: 1, signal: null }
REQUEST onRequestResponse 200 { server: ‘CouchDB/1.5.0 (Erlang OTP/R16B03)’,

Second block of errors_

npm ERR! git clone --template=/Users/rodolfosantos/.atom/.apm/_git-remotes/_templates --mirror /Users/rodolfosantos/.atom/.apm/_git-remotes/https-git-github-com-yyx990803-vue-git-2062c581: dyld: lazy symbol binding failed: Symbol not found: ___strlcpy_chk
npm ERR! git clone --template=/Users/rodolfosantos/.atom/.apm/_git-remotes/_templates --mirror /Users/rodolfosantos/.atom/.apm/_git-remotes/https-git-github-com-yyx990803-vue-git-2062c581: Referenced from: /usr/local/git/bin/git
npm ERR! git clone --template=/Users/rodolfosantos/.atom/.apm/_git-remotes/_templates --mirror /Users/rodolfosantos/.atom/.apm/_git-remotes/https-git-github-com-yyx990803-vue-git-2062c581: Expected in: /usr/lib/libSystem.B.dylib
npm ERR! git clone --template=/Users/rodolfosantos/.atom/.apm/_git-remotes/_templates --mirror /Users/rodolfosantos/.atom/.apm/_git-remotes/https-git-github-com-yyx990803-vue-git-2062c581:
npm ERR! git clone --template=/Users/rodolfosantos/.atom/.apm/_git-remotes/_templates --mirror /Users/rodolfosantos/.atom/.apm/_git-remotes/https-git-github-com-yyx990803-vue-git-2062c581: dyld: Symbol not found: ___strlcpy_chk
npm ERR! git clone --template=/Users/rodolfosantos/.atom/.apm/_git-remotes/_templates --mirror /Users/rodolfosantos/.atom/.apm/_git-remotes/https-git-github-com-yyx990803-vue-git-2062c581: Referenced from: /usr/local/git/bin/git
npm ERR! git clone --template=/Users/rodolfosantos/.atom/.apm/_git-remotes/_templates --mirror /Users/rodolfosantos/.atom/.apm/_git-remotes/https-git-github-com-yyx990803-vue-git-2062c581: Expected in: /usr/lib/libSystem.B.dylib
npm ERR! Darwin 12.6.0
npm ERR! argv “/Applications/” “/Applications/” “–globalconfig” “/Users/rodolfosantos/.atom/.apm/.apmrc” “–userconfig” “/Users/rodolfosantos/.atom/.apmrc” “install” “/private/var/folders/t2/7_2gc72n5t3bvps6bnkqdhn80000gn/T/d-116311-2916-1hub8v/package.tgz” “–target=0.34.5” "–arch=x64"
npm ERR! node v0.10.40
npm ERR! npm v2.13.3

npm ERR! Command failed: dyld: lazy symbol binding failed: Symbol not found: ___strlcpy_chk
npm ERR! Referenced from: /usr/local/git/bin/git
npm ERR! Expected in: /usr/lib/libSystem.B.dylib
npm ERR!
npm ERR! dyld: Symbol not found: ___strlcpy_chk
npm ERR! Referenced from: /usr/local/git/bin/git
npm ERR! Expected in: /usr/lib/libSystem.B.dylib
npm ERR!
npm ERR!
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR!

npm ERR! Please include the following file with any support request:
npm ERR! /private/var/folders/t2/7_2gc72n5t3bvps6bnkqdhn80000gn/T/apm-install-dir-116311-2916-kpvftg/npm-debug.log

hope this help.

For info I’m running Rhino 5.1 5B161 Educational.
I use it to teach computational design.

Best regards

It looks like some networking issues but I can’t tell if it’s your firewall or npm having problems. Can you try to run the following command?:

```git config --global url.“”.insteadOf`

and then try again?

Doesn’t help here.
I’m not using any extra firewall on the mac.

I send you the full log in case you want to examine it or send it to a colleague … I’m afraid I’m lost with this issue.

error log RS.pdf (28.4 KB)

Also : Turner FileVault off and Firewall off on the mac to test.

Here’s the last settings on my machine

iMac-de-Klik:~ rodolfosantos$ apm -v
apm 1.6.0
npm 2.13.3
node 0.10.40
python 2.7.2
git 2.7.1
iMac-de-Klik:~ rodolfosantos$ which git
iMac-de-Klik:~ rodolfosantos$ echo PATH /usr/local/git/bin:/usr/local/git/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin iMac-de-Klik:~ rodolfosantos export
declare -x Apple_PubSub_Socket_Render="/tmp/launch-K1vHIj/Render"
declare -x Apple_Ubiquity_Message="/tmp/launch-1jgxeu/Apple_Ubiquity_Message"
declare -x COMMAND_MODE=“unix2003"
declare -x HOME=”/Users/rodolfosantos"
declare -x LANG=“fr_BE.UTF-8"
declare -x LOGNAME=“rodolfosantos"
declare -x OLDPWD
declare -x PATH=”/usr/local/git/bin:/usr/local/git/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin"
declare -x PWD=”/Users/rodolfosantos"
declare -x SHELL="/bin/bash"
declare -x SHLVL=“1"
declare -x SSH_AUTH_SOCK=”/tmp/launch-Q1x70j/Listeners"
declare -x TERM="xterm-256color"
declare -x TERM_PROGRAM="Apple_Terminal"
declare -x TERM_PROGRAM_VERSION="309"
declare -x TERM_SESSION_ID=“EC0D8D85-0FD5-422C-8937-7EA2A64D0037"
declare -x TMPDIR=”/var/folders/t2/7_2gc72n5t3bvps6bnkqdhn80000gn/T/"
declare -x USER="rodolfosantos"
declare -x __CF_USER_TEXT_ENCODING="0x1F5:0:0"
iMac-de-Klik:~ rodolfosantos$

logged as admin


I don’t see the problem. Let me do a few tests and I’ll get back to you …
Thanks for reporting it.

Can you try installing the package again? Version is now 0.8.1.

Hi Alain.

I’m working till 9PM today (local time UTC), I will make a try when I’ll be back ,around 10PM.


Hi Alain.

I tried to install the package again and received the attached logs.

I tried through Atom via Atom and terminal.
I noticed that the install process take more time than before, but then it failed again.

terminal output RS.pdf (49.2 KB)



It’s hard to figure out because I can’t reproduce the problem but it definitely looks like a network issue. The test you did last night would not have worked so I reverted the change.

I reread your response “I’m not using any extra firewall on the mac”. Are you behind a corporate firewall?

Nothing spacial, Alain

here’s my situation regarding the DSL settings.

Screen Shot 2016-04-13 at 20.15.26.pdf (48.8 KB)
Screen Shot 2016-04-13 at 20.15.00.pdf (87.6 KB)

I’m behind a standard router with a internal firewall . Is there something related to the NAT/DynDNS/UpnP settings that may explain my problem.
I don’t really catch what kind of request is sending ATOM to install the package?



Considering your comment about the network I tried to access the net through my mobile phone.
I tried to install the package again and received this.Screen Shot 2016-04-13 at 20.57.13.pdf (60.3 KB)

Hope this help.

Ok Alain.

I looked for similar issues on the net following your comments about the network and found a thread talking about the version of git that should be installed on the OSX 10.8.
The advise is to install GIT 2.2.1 for Snow LEOPARD VS Maverick

After installing the recommended version I could install the package through the terminal with your command line. I did a first test to link Rhino and it seems ok (Have to control that again).

Its hard to face a problem and solve it that way without really understanding what’s the problem.

here’s the link to the thread

I will test atom tomorrow (late here) and will let you know what’s going on.



Till now the bridge Atom-Rhino is working…
I still not figure out what may explain the error messages I received when trying to Git declare on my Mac.

Installing Atom is an easy process, but understanding Git and the PATH modification is not intuitive for non experts like me. There are tones of threads suggesting to do this and that or the opposite, it’s a real jungle.

May I suggest to McNeel to publish an official dedicated thread where mac users will be able to find a list of know issues and how to handle it in an appropriate way.
There’s a lack of clear info’s on the net, I didn’t expected to run into so much problems.

Then I really wanted to thank you for your efforts, Alain.
I teach Rhino on windows as an ATC for a while and I know that McNeel is a great company offering a strong support to the community.

Developing Rhino for Mac is a long process and I’m very happy to run it on a mac.
Users, experts and non experts, are on the front line to give a feedback and support the dev team @ McNeel.


Thank you for your information. I had the same problem and I solved it by following your steps.