Atom and Python not working with Rhino 5.3.2 and WIP


#1

Hello.
I have been learning Rhino for Windows in a digital fabrication class and recently installed Rhino 5 on my MacBook Pro to try out the Mac version.
I was hoping to use python to generate several interpolated curves from many data points.
I have a decent amount of python experience for exactly this situation - not as a real developer, but I use it all the time for solving problems like this.
However, after following the instructions to set up Atom with Rhino, I can’t run even a simple example script.
The Atom end appears to work fine (Rhino syntax autocompletion is working, RhinoPython appears in the packages menu), and I’m making sure that the Atom listener is running in Rhino. But every time I chose “Save and run in Rhino” from the Atom menu or use the ctrl+opt+R shortcut, I get an error in Rhino:

Exception occurred
Message: ‘module’ object has no attribute ‘AddLine’ (or AddCircle or whatever)

When I look at the info for both Rhino 5.3.2 and Rhino WIP, it tells me IronPython is not installed, but I thought this was supposed to be included with Rhino automatically?

Here is more info:
Software information

Software versions
Rhinoceros version: 5.3.2 (5D197)
IronPython version: not installed
Evaluation expiration: June 27, 2017
Language: en-US (MacOS default)
macOS version: Version 10.12.3 (Build 16D32)

Plug-ins
None

Third party kernel extensions
com.Cycling74.driver.Soundflower (2) 2D779840-7439-31E5-8A66-D786C3F47B75

Hardware information

Computer hardware
Hardware model: MacBookPro12,1
Processor: Intel Core i7-5557U CPU @ 3.10GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel Iris Graphics 6100 1536 MB
Memory: 1536 MB
Screen size: 1440 x 900
Displays: Color LCD (256dpi 2x)

USB devices
Broadcom Corp.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-10.22.29
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#2

can you post a little example script that fails?
(just to make sure the formatting/syntax is correct)


#3

Sure thing!

import rhinoscriptsyntax as rs
from Rhino.Geometry import Point3d

rs.AddCircle(Point3d.Origin, 5.0)

Produces this error:
Exception Occured
Message: ‘module’ object has no attribute 'AddLine’
Traceback:
line 7, in , "/Users/ersheff/Desktop/rhinoscript.py"
line 2, in , "/Applications/Rhinoceros.app/Contents/Resources/ManagedPlugIns/RhinoDLR_Python.rhp/RssLib/rhinoscriptsyntax.py"
line 1, in , “/Users/ersheff/Desktop/rhinoscript2.py”

While

import rhinoscriptsyntax as rs

startPoint = [1.0, 2.0, 0.0]
endPoint = [4.0, 5.0, 0.0]
line1 = [startPoint, endPoint]

line1ID = rs.AddLine(line1[0],line1[1])

Produces this error:
Message: ‘module’ object has no attribute 'AddLine’
Exception Occurred
Traceback:
line 7, in , "/Users/ersheff/Desktop/rhinoscript.py"
line 2, in , "/Applications/Rhinoceros.app/Contents/Resources/ManagedPlugIns/RhinoDLR_Python.rhp/RssLib/rhinoscriptsyntax.py"
line 1, in , “/Users/ersheff/Desktop/rhinoscript.py”


#4

I should reiterate, in case it was missed in my first post, that Rhino reports IronPython as “not installed” in the Rhinoceros Information.


#5

yeah, both of those scripts are ok (and work for me via Atom).

i don’t recall seeing a case of iron python being listed as not installed.
(for reference, a screenshot of my rhino info):


this is a case for the bigger brains… :wink: they might not see this post until tomorrow.
good luck


#6

Thanks for checking it out!
Yeah, this stumped me. The only result I get when searching for “IronPython not installed” is a post that specifically states it became included automatically with the standard Rhino installation a long time ago!


#7

yes, it’s included in Rhinoceros.app…

python should work for you in rhino without installing anything else.
something is broken (for lack of better word)


(Dan Belcher) #8

It sounds like you are currently evaluating Rhino 5 for Mac. Did you validate your trial license? If you are not prompted - frequently - to validate your license, then that is a bit of a problem. In the meantime, what happens when you run _ValidateLicense? If you validate, then restart Rhino, and python still does not load, please let us know.


#9

Trial license was validated upon installation - says I still have 88 days left. Validation confirmed in Rhino with _ValidateLicense. Rhino restarted, computer rebooted to be thorough. Python scripts from Atom still fail with the same messages posted earlier. Still shows IronPython as “not installed”.
I should mention that while my default Python path in macOS is the regular version of Python supplied by Apple (2.7.13), I also have Python 3.6 installed through Homebrew. Don’t know whether this is relevant - I assume it wouldn’t cause any issues as the 2.7.13 is still the default.


(Dan Belcher) #10

Thank you for doing those steps first. Please try uninstalling and reinstalling next.


#11

Hello. Thank you for the prompt reply.
I followed all uninstallation instructions at the provided link, re-downloaded, re-installed, and re-authorized, and Atom/Python still doesn’t work. Produces the same errors as posted earlier in the thread, and IronPython still shows as “not installed”.


#12

I have seen this before, related to your system python I believe. Do a google search for reinstalling your macOS python.

Look here for linking to Atom, I believe last link in that post …

IHTH «Randy


#13

Hello. I am reluctant to uninstall my default system Python installation since I have multiple versions of Python (including the default macOS installation) running just fine outside of Rhino. I have not changed my default Python path, either.
Did you look at my other posts? Rhino is showing that IronPython is not installed, even though I downloaded and installed (and uninstalled and re-installed) Rhino 5.3.2 multiple times in the last few days.
I am using Python almost daily outside of Rhino and have already followed the instructions for setting up rhino-python. It appears that Rhino is not correctly loading dependencies to run scripts since Atom IS talking to Rhino, but Rhino throws up an error that indicates it doesn’t know anything about “AddLine” or “AddCircle” or whatever I throw at it.


#14

Hello.
Sorry to be a pain. Any other ideas on this problem?
Still showing “not installed” for IronPython. I would really love to know that this is working before purchasing the full license for Mac.


#15

i’m pretty sure if you had a fresh install of macOS, it would work fine.
i’m imagining the problem is due to installing other pythons on the computer