Arctic Display mode data isn't saved in file

Hi All.

I’m curious, why Shaded display mode info is saved in file and it’s displayed immediately after opening.
And Arctic mode doesn’t do that. It requires time to calculate it again.
Both modes have OpenGL Pipeline in settings.

Hi @Screamer,

I tested saving a model in Arctic mode, closing and reopening. This displays the model in Arctic shading immediately. Are you saying it is recalculating the display mesh?

Hi @Gijs

Yes, exactly.
Did you try to do this with heavy model? Which takes some time to create rendered meshes for Shade mode?
Maybe for simple model it’s not so obvious.
Unfortunately I can’t share my file.

It’s a pretty dense model I tested this with, no mesh recreation here…
Of course if you use _SaveSmall then it will recreate the mesh. But I assume you know this, besides, you say that the model opens shaded models right away. So if you save the mode in shaded, then open it and switch to arctic, do you see a similar delay? How much time does it take?

Am I correct that as soon as we have opened model in shaded mode switching to Arctic should be in a moment? As we already have rendered meshes.

Do you really mean “Arctic” or are you talking about “Artistic” mode? There is nothing special about Arctic mode, other than it uses AO shadows… If you’re seeing any kind of delay switching to Arctic mode, then I’d expect the same delay if/when switching to Rendered mode… Do you get a delay when switching to Rendered mode?

If you really mean “Artistic” mode, then yes, there will always be an initial delay for calculating the “technical info” that is used to produce some of the technical drawing effects more efficiently (i.e. intersections, hidden lines, etc…). There are no plans to store that information in the 3dm file. There are plans to completely do away with most of those calculations, and move the features into all display modes… This has already started to happen in V8…whether all of it makes it into 8.0 remains to be seen, but eventually it will all be in 8.x.

Given that, please clarify: “Arctic” or “Artistic” ?


1 Like

Hi @Gijs

Yes, it was about Arctic.
I’m sorry to say this, but today I opened the file with saved shaded info in it and it switches to Arctic in a moment (and rendered as well).
I don’t understand why I had such issue before. And it wasn’t one attempt only.
I believe shaded info wasn’t saved properly. (The file is big and I didn’t save it often)
So I think there is no issue with that. My bad.

Since we’re talking about Display modes I have another thing.
I have duplicated Shaded mode and renamed it. Changed some properties.
And from time to time it disappears from the list (The name changes). I had a message one time, something like this: “You have a display mode same as Shaded. Switch it to the shaded?”
As a result - two Shaded modes. They are different in settings, but have same name.

Hi -

I’ve seen display modes change the name, yes, but never heard about a message saying something like what you are reporting.
Please run the Rhino SystemInfo command and copy-paste the result here.

Hi @wim

Sure, here it is:


Rhino 7 SR26 2023-1-9 (Rhino 7, 7.26.23009.07001, Git hash:master @ 92abcf7c453c78a236526390d91d0ac1f6779143)
License type: Commercial, build 2023-01-09
License details: Stand-Alone

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro RTX 5000 (NVidia) Memory: 16GB, Driver date: 11-23-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 527.27
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 5-26-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-23-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 6\Plug-ins\DATAKIT\Rhino6_Import_x64.rhp “Datakit_to_rhino6”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\ClippingBox (4dfff1df-5f09-43ae-a044-77b115244b02)\\Rhino 6\ClippingBox.rhp “ClippingBox”
C:\Users\User\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\Iris\0.7.1\Iris.V7.rhp “Iris”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\User\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

I think it wasn’t a popup. It was in Command line if I’m not mistaken.

Hi -

If this happens again and you can get the exact wording of that message, we can probably try to find out where in the code that might be triggered. You have a few 3rd party plug-ins, so it could be one of those that produce that. At any rate, please let us know if you run into this again.

1 Like

Hi @wim .

I’m still facing this issue (with name resetting).
I just tried to import my saved Display mode (which name is RenderedColor) and got this message.
Maybe that code part you may look for is nearby this message?


And still have that issue with Arctic calculation while having Shaded already shown.
It happens not consistently.