Archicad Live connection tab not showing in Grasshopper

I recently installed the Archicad Grasshopper live connection. I get no warning during the installation. The tool is showing up in Arhicad but I do not get a new tab in Grasshopper. What am I doing wrong?

Running latest version of Archicad 22, Rhino 5 64-bit test version in Windows 10…

@kike, do you have any experience with this?

Do you have the file C:\Users\wim\AppData\Roaming\Grasshopper\Libraries\ARCHICAD 22\ArchiCADConnection.gha?

Actually the file is not in the grasshopper folder. The installation process was not displaying any warning though. Can I download the grasshopper file somewhere and place it manually in the GH folder?

Be sure you have lunched the 64 version of rhino , otherwise you will not have the tab (or any compatible 64bits plugin) displayed.

installation failed due to administrator settings. I got it all solved. thanks.

Hi, i got similar problem on Rhino 6, could you please tell me how you solved that ‘administrator settings’?

Well it was connected to me not having write rights on some directories. Check that first.

I’m getting this problem again and again.
The plugin gets installed in archicad, and during the installation the installer unpacks the *.gha file, but when I go to the Libraries folder it is completely empty (I made a fresh Rhino install in case it was the problem)
Any help would be appreciated!

Hi Miguel -

I’m not an Archicad user and am not familiar with that plug-in. Are there any instructions that come with the plug-in? Do you know where the *.gha file gets extracted to? You should probably be able to find it on your hard drive somewhere.

What is the path to that folder?
-wim

1 Like

Thx @wim I took that route. I don’t know why or even if it should have worked that way but it was getting extracted to the Rhino Plugins folder. I cut it from there and pasted it in the libraries folder and everything works.
BTW I had to make a slow-mo capture of the extraction on the installer to be able to read the *.gha file and look for it…

Hi everyone.
I have the same problem and I can´t solve it.
I´m running Archicad 23 and Rhino 6 and downloaded the latest version of the grashopper Live Connection for Archicad.
At first I get a grasshopper breakpoint message when I open grasshopper in Rhino (first image) and then I can´t install the missing components (second image).
Archicad Live Connection tab is also not showing.
The ArchiCad Connection.gha file is located in the Rhino6/Plug-ins/Grasshopper folder. I´ve etried Miguel´s solution but didn´t work.
Any help will be greatly appreciated.
Thank you very much.

Hi -


You are running Rhino 6.3!
The plug-in that you are trying to use requires 6.14 or newer. The current stable version is 6.29.
-wim

Hi Wim!
I updated Rhino to the latest version and the problem was solved.
Thank you very much for your help! I really appreciate it.