Annotation Text Settings : No "Model Space Scale" option?

Without this option, the texts that I bake inherit a default value of 10.

Did I miss something ?
Is there a secret way to activate that extra input on the “Annotation text settings” component ?
Like in an escape game ?

By the way, for my annotation needs, I couldn’t care less about most of the options proposed on this component, but “Model Space Scale” could sure come in handy to prevent this :

Hi Osuire,

That can be changed per object via the Annotation Style Override component.

My eyes bleed, but I get it.
Thanks.

Sadly, this scaling factor seems completely ignored at bake time…

Also, I wish there was no “default” text for the text entity component.
I don’t want to see a silly “Abc” preview in Rhino when I don’t feed any text.

Hi Osuire,

Not seeing the issue here on a quick test in the latest.


Friggin text scaling.gh (9.5 KB)

You didn’t set your text height, so I’m not sure what you are proving here.

This is working as expected.

Are you thinking of the ScaleTextHeight command in Rhino?

https://docs.mcneel.com/rhino/8/help/en-us/index.htm#commands/scaletextheight.htm?Highlight=Model%20Space%20Scale

A text of height 100 with a model scale of 1 should be 100 units high, not 1000.
Are you paying attention ?

Your model scale is 10 in the example above, I tested your file and 1 x 100 is correct as is 10 x 100.

I’m assigning this to the devs, not sure what to make of it. Thanks for your inputs.

What do you mean “My model scale” ?
The idea is to SET the model scale in GH.
So why does a 1 turn into a 10 when I bake the text ???

Text in Rhino is such a hassle, an AutoCad legacy.

When I opened your file and baked the text into the document, the text shows a height of 100.0 and a model space scale of 1.0… which are the same settings used in Grasshopper. Am I missing something?

Hi Andy.
That’s weird. In my case, the scaling becomes 10.

I have worked over 10 years making detailed and annotated drawings in Solidworks. I NEVER worried about scaling factors for text, leaders or dimensions.

By contrast, in AutoCad and thus Rhino, management of annotations is a job in and of itself ; a boring, soul crushing one at that, leading to silly discussions like this one.

I’d also like to report a new bug : invisible text edits.
I can’t see the text I’m typing while editing an existing text, yet the updated text appears in Rhino viewport. Not systematic.

Hi Olivier -

I seem to remember having run into that in the past but am not able to reproduce that at this point. Which version of Rhino are you currently running?
-wim

Hi Wim

Version 8 SR8
(8.8.24142.13001, 2024-05-21)