Annotation style definition

A few observations during some experimentation with the new style properties. This might be too early to come with feedback on all of this so just take it for what it’s worth :smile_cat:

  • First off, thanks for continued work on this area!

  • Trying to modify an annotation style always crashes Rhino on one PC - I sent in a couple crash reports.

  • Ref. discussion on the size of dimensions in RH5:
    When I use text height 3 units and Model space scale of 70 and then place a dimension on the layout, the resulting height is 210 whereas it should be 3.

- I made a brand new style based on the built-in "Millimeter Architectural" style with height 5 units and Model space scale 70. According to the text in the panel, this results to adjusted text height of 210. The file is copied from RH5 and another style with the same settings results in adjusted text height of 350 (which sounds more correct): RH5 existing style:

New style:

Update: I just closed the options page and then went back in and now the text height of both styles is set to 3. !? :confused: - The preview pane shows a factory-default drawing when a perspective view is active. When a parallel view is active, the preview pane shows part of the TOP view. The factory-default drawing doesn't help at all when trying to find out a good size for a dimension. The TOP view is shown also when e.g. the RIGHT view is active. It might then as well show the TOP view if a perspective view is active.
Update: It doesn't look like I can reliably predict which view will be in the preview pane... It's even possible that this preview doesn't show ANY dimensions at all! Which is not very helpful. Perhaps we should be able to pan and zoom in this preview pane.

  • The preview doesn’t reflect an update to the Dimension Text Placement.
  • Unrelated to the annotation definition - I:
    It looks like details in layouts no longer support display modes with shadows turned on.
    Perspective detail in regular out-of-the-box ‘Pen’ display mode:

Modified 'Pen' mode (only change is that I turned on shadows)(part of the effect is after zoom & pan of the layout):

- Unrelated to the annotation definition - II: History and scaling details. When I turn history on and snap a dimension to a model in the detail and then change the scale of the detail, the dimension is not updated. You can force it to update when you then pan the view in the detail. Place dim:
Check scale:
Change scale:
Panned view:

- Unrelated to the annotation definition - III: The previous picture shows that when a dimension is placed with history on, the history is destroyed when the style of the dimension is changed (i.e. not the definition of the annotation but a different style is chosen from the list of existing ones).

- Unrelated to the annotation definition - IV: In the following picture of a layout, the orthographic details are set to the Technical display mode. The dimensions that are seen in the TOP view (upper left) are placed in model space whereas those in the RIGHT view (bottom right) are placed on top of the layout. Dimensions shown in Technical display mode inherit characteristics from the Rhino Options > View > Display Modes > Technical > Objects > Lines > Silhouette line width (pixels): setting. I don't think that is right.

@lowell I think this is for you.

Thanks for the feedback - I’ll see what I can do here…

About the crashing editing styles, we’ve had one other report that sounds similar, and the guy who sent that also sent crash dumps, but none got through to us. I haven’t seen any from you either. I filed a bug report about the crash dump process but nothing has happened there that I know of. I’ll check on that again.

About the text not scaling correctly in layouts - I found a problem that has to do with using a v5 file that had annotation scaling turned off. There’s no control for that in V6 but it looks like the residual setting still defeats it. I haven’t dug into that yet,
Did you see that problem in a file from V5 that had scaling off?

About getting the wrong size multiplied from text height and model space scale - There was a bug fixed in the last couple of days that fixed a problem of the style edit page not updating properly when you change from one style to another and having some settings carry over from one to another. So pretty unpredictable what you might see. Hopefully that is ok now. I think that may have also been the problem of settings not sticking or not seeming to stick.

The preview in the style dialog isn’t supposed to show your model. It’s supposed to show a static image with a few sample dimensions.
I’m not sure where to start on that one - It has to do with making a temporary display pipeline and drawing into a bitmap. The temp pipeline is supposed to skip your model geometry. It looks like something isn’t getting changed properly. I’m not looking forward to trying to figure that one out.

I think drawing in details is kind of dodgy on a few fronts. I’ve filed a couple of bugs lately myself. It’s being worked on, and I’m not real current on the status.
I got something similar to what you did when I turned on shadows in pen mode in a detail and I filed a bug.

Dimensions in Layouts and History are still pretty rough. In the few real drawings I’ve done, I’ve always had to make dimensions in model space. Maybe that can improve. I hope so.

I don’t see the same thing as you about dimensions drawing with the silhouette line properties. I’ll look at that some more.

Thanks again for the reports

I just uploaded the Rhino.exe.14636.dmp that was saved to C:\Users\Wim\AppData\Local\CrashDumps when I crashed it just now.

My WIP uses the same template file as my RH5 and (I would have to check to be 100% sure) I believe that Model space scale is set to 1 for all styles.

It did show that static (I called it dynamic because the dimensions would -partly- update) image when a perspective viewport was active.

Since you are not looking forward to trying to figure that one out - why not go back to the RH5 method where you press the Preview button to see changes in the viewport. For me, having this static image only giving some feedback was not very useful.

So do I :wink:
At this point I’ll restate my wish to have history turned on by default when placing a dimension. But that does require the history to work without problems first.

No problem. I wasn’t sure if it was too early to come with these.

A couple others then: (and on my crashing 'puter now so no images and not the correct wording)

  • I saw that one could make leaders with a spline. I tried using that but always got a polyline.
  • Custom arrows - I found no way of making these.

I got the dmp file. It looks just like the other one I saw. At least to that degree it’s repeatable.
I think you’re saying you have one computer that crashes all the time editing styles and one that doesn’t, right?

So far, the only thing I’ve found that relates to this is whether scaling is enabled in the v5 file, not what the scale is set to. If scaling is not enabled, the dims don’t scale right. (A bug)

So, when perspective is active, you get the image I posted and when another vp is active, you get part of that vp?
I’ll get an apply or preview button back for that page, and hopefully get the image to draw right.

There is a test command, RLeader, that makes leaders that can have spline arrows.

Test commands like DimLin, DimAng, DimRad, … make dimensioins that can have custom arrows. RLeaders can too.
The arrows are from blocks one unit long at the origin.

Neither those new dimensions nor RLeaders save in files yet.

It’s not too early to send those things in from my end anyway. Some of that stuff is being worked on. Some of it is known and down the line somewhere. Some of it is new and very good to know about. It may not be worth a lot of time for things that haven’t been announced but I’m happy (well, not really happy, but it helps the process) to get the reports.


That is correct, yes.

OK. In my RH5 template (also used by the WIP) the scaling is not enabled.

Well… I now would put that sentence in the past tense. I now always get the image you posted and I cannot repro getting part of the vp. I’ll fool around a bit when I get the time but this might be hard to track down.

And I’ll play a bit with the test commands as well.


@lowell, the current weekly is almost 2 weeks old now so this might be old news…

  • The annotation style definition doesn’t have a “Text Gap” setting anymore.
  • “Dimension Text Alignment” doesn’t do anything in my tests.
  • Leader text alignment doesn’t do anything in my tests.
  • The centermark style “Mark and Lines” doesn’t work in my test.
  • There are a few issues with the tolerances. Symmetrical > resolution > always becomes ±0.0000. The height always is 100% even when lowered in the setting.

Thanks, Wim.
Text gap is an oversight that needs fixed.
The rest are settings that will make a difference with new annotations that are still in test commands.
But, I should at least try to make the current dimensions usable in places where they’ve gone backwards