Anemone very slow, when data is not internalized

Hey guys,

I am working on a project for university, where I am relying a lot on Anemone. Strangely it takes forever to compute the loops - even with very simple operations. As seen in the screenshot, I am just going through the items of a list, which takes around a 1 second. Other operations like blending a set of curves takes even more than 4-5 seconds.

The problem is, that those seconds acumulate, which results in a VERY slow gh-definition.

Interestingly, when I paste a definition which blends together some curves into a new gh file, everythings runs completely smooth (11ms vs 753ms)…

Is someone familiar with this?

Find the .gh-file, screenshot and system_info attached below…

Best wishes, Rudi

system_info.txt (2.0 KB) (160.5 KB)

I can only see that something strange is happening with the “Geo” parameter:
it says there are 3 “Trimmed surfaces” but then if you bake them some are actually breps (polysurfaces).
Your internalized parameter do contains 2 “Open brep”, but i can’t replicate it …

Hey Riccardo, thanks for looking into it.

Yes, that was some other issue probably caused by the bad creation of the sweeping profiles. I fixed it now, but the problem still remains…

Check out the updated file! (109.2 KB)

I replaced the internalized data with his other geometry and internalized it again. I could replicate the whole problem.

1 Like

I tried to isolate the issue… whats interesting, is that even when I run a ridiculously simple loop, like going through a number series it is still very slow.

Whats more, is that I am working on a bigger skript and the more components the script has, the slower it gets, as can be seen in the screenshot below.

And here the current complete script:

Would awesome if someone could help me out here :stuck_out_tongue:

In case no further poweruser reply come… i might say:

It’s hard to guess why a plugin component is slowing down (from a common user viewpoint)

How much complex is your iterating in anemone?
Couldn’t you give a chance to script components? (I could give some help in c# … still a rookie anyway)

Also… don’t make such big definitions!
1 - If you ever will need help there… noone is going to search through all of that (not even yourself in future!)
2 - That’s just scary!

I’m not expert regarding Anemone, but could it because the “Record” option is on fast-loop-end component settings?

Here is an example of a crazy simple loop… The problem has to be somewhere else.

Any further suggestions would be much appreciated.

Cheers, Rudi