Ampersand issue when using Ø, °, etc

There is a problem if you try to edit a string of text that contains an ampersand and a unicode character.
Take a look:



Hi Dan- checking it, thanks.


Thanks Pascal.

Have a good weekend,


Hi @pascal,

There is something similar happening with Text Objects but it doesn’t relate to the inclusion of a non-text character.

If you place curves using the string Porgy&Bess and then reopen the Text Object panel the text will now read Porgy!!amp!!Bess. If you then place curves without doing any editing in the Edit Box then you still get the ampersand curves, but if you do any editing of the text, even if you reverse out the change(s), then you get curves for !!amp!!. So far I get this behaviour with all the half dozen fonts I have tried, except for Arial which I have not been able to make fail (slightly bizarre to get a font specific exception?).

And if you toggle Allow Single Stroke Fonts and change the font selection you can sometimes trigger the !!amp!! replacement there and then, without going near the OK button.

Can these be added to the investigation, please.