Alt behaviour

I use shift and alt a lot to toggle between states. Holding shift to toggle ortho and holding alt to toggle osnaps.
Another handy trick that has dropped off the last few updates is holding alt select a small object in front of a large object. Say the screen is filled with a large object, with a few small objects in front of it. A standard marquee will select and drag the large object. But holding down alt while dragging the marquee used to disable the select, while being able to select objects within the boundary.

This doesn’t seem to work now. Holding down alt will disable the drag, but for some reason the objects within the marquee no longer select.

Is there any way to reinstate the old behaviour?

Hi Andrew - as far as I know that has not changed - can you provide an example?


Hi Pascal, I updated to the latest version over the weekend and am not experiencing the issue now. I’ll report back if I see it again.

Hi Pascal, Try this file. I can only select the small highlighted objects in wireframe using a normal marquee. If I use alt-select in shaded, ghosted or any other rendered mode, I skip the click-drag but the objects don’t select.

Are you getting this?

cant_alt-select.3dm (623.4 KB)

Hi Andrew - this worked here as expected. I’m not sure what to suggest - are there files where it does work?


Hi Pascal,

Seems to be all files.

I’m getting some other errors as well. Not sure if it’s related:

  • My lighting scheme seems to go haywire when I try to print a PDF drawing. So all viewports and sun/skylight look as expected and when I hit CtrlP and see the preview, all the rendered details go to a strange dark shadowy display (which is what prints). And after printing, changing the sun and skylight settings has no effect. I need to restart rhino to get things working again…
  • When drawing a line (for example) I used to hold down shift to toggle Osnaps. This still works but now initiates Elevator mode to finish off the line.

Any ideas what this could be?

Hi Andrew - sounds like something is seriously amiss - Shift down should toggle Ortho, Alt should suspend OSnaps and force a window selection, and Ctrl should invoke elevator mode. Can you run SystemInfo in Rhino and post the results?


Hi Pascal,
Sorry I got that wrong, it’s when I hold down ALT that I get Elevator mode. It does toggle OSnaps but it also initiates Elevator mode as well…

Here is my SystemInfo:
Rhino 6 SR17 2019-7-8 (Rhino 6, 6.17.19189.16411, Git hash:master @ cf56edd2ae6f54f60e146e5c7b3fb2f75e4fe114)
License type: Educational, build 2019-07-08
License details: Cloud Zoo. In use by: Andrew ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-CGD5BFJ

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro 4000 (NVidia) Memory: 2GB, Driver date: 1-13-2018 (M-D-Y). OpenGL Ver: 4.5.0 NVIDIA 377.83

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 1-13-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.17.19189.16411
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.17.19189.16411
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.17.19189.16411
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.17.19189.16411
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I’ve just discovered something, I’m left handed so use the right side alt, shift, control buttons most of the time.

I just tried the left Alt button and it works as expected (including the window selection). So it seems maybe my right Alt button has been reprogrammed? Is there a way to correct this?

Hi Andrew - Hm. I have no idea - is there some Windows UI utility on your machine?