After OffsetSrf MatchSrf inoperative..why and what to use?


#1

Hi
V5
I have ensured no naked edges, used MatchSrf on any that showed. then used Join. Checked again no naked edges.
OffsetSrf 2mm and I get a 1mm split in one part of the model.
However run MatchSrf and it wont select anything.

Explode the model and still MatchSrf wont select anything.

JoinEdge will , dead easy. but one must never use that command.

How do I fix the little crevaces that OffsetSrf 2mm has gone and caused, and this not so little one, as is its habit ! The starting shape was a fine piece of work but offsetSrf will wreck things.

Steve


(Gustavo Fontana) #2

Matchsrf should work in your offseted surfaces, unless they offset process is trimming them. You can only match untrimmed edges. Can you try to untrim (keep boundary curves), match, and then retrim with some edited version of the original trimmed curves?

G


#3

Hi,
Thanks for the advice,
I ran Untrim on that split and it healed up in that moment ! That means OffsetSrf had trimmed, should it do that ?

What was a straightforward carefull sweep2 shape with 11 separate sweeps each of to two rails so surfaces share a common edge, with OffsetSrf it sees a long thin removable wall along one joint created, another T seam is now an offset kinky T.

a 1mm crevasse appeared on one side yet on the other side of this symetrical shape it was fine.

I ran MatchSrf on another edge that shows naked edge and it decided to fill over the entrance of this object.

I shall start a new thread on how best to fuse surfaces before OffsetSrf as I am to be faced with many offsetSrf tasks and cant be having this.

MatchSrf will bridge gaps but doesnt join surfaces, I still then have to select them all and go JOIN.

Steve


(Gustavo Fontana) #4

Take a look at the ‘loose’ option of OffsetSrf. It makes an offset surface with same topology/point count of the original surface. Which of course cannot be a perfect dimensional offset. Because math.

G