Problem Matching Rhino and Maxwell (Plugin) Render


#1

Hi guys,

I have a really irritating problem I have been trying to solve for a while. I am using Maxwell render plugin for Rhino as my engine, and the problem is that the angles does not match. I am trying to render an isometric view (30/60 degrees), where I use the command ‘Isometric’ to set the viewport, then after I render using Maxwell, the angles does not match; it is slightly off from the viewport. I have searched sites and looked everywhere but there seems to be no way to fix this. Can anybody please provide any existing threads or help with this?

Thanks in advance!

Note: I will provide comparison pictures if the problem is still not clear.


#2

Seems to work fine here, but I only checked with a simple box. Maybe @jdhill could have a look?


#3

It does work for simple boxes (as shown in the image provided) but not for more complex/larger objects for some reason. I thought that maybe it’s because of the specific file (which may be corrupted or something) but I tried copying the model to another file, and it still does not work.


(Menno Deij - van Rijswijk) #4

Could this be because the object is very far from the origin and the problem is due to rounding errors?


#5

Dear Menno,

This may be possible, since my actual model is quite large (longest distance is around 14,500 cm) but would it have that much difference in angle? If that’s the case, is there anyway to solve this?


#6

Physical size doesn’t matter. But placing items very far from the model origin (kilometers) may cause problems. Check if this is the case, otherwise posting a simplified file might help.


#7

Still having problems with this.No matter which angle, rhino and maxwell never matches. I’m having trouble making 2d and placing it on top of maxwell render. Any help is appreciated, I am having lots of trouble with work.
Thank you!


(Brian James) #8

Can you provide a 3dm file that shows the error?


#9

Thank you for the reply, the file is a little to big to upload (530mb). The problem is just that maxwell does not match with Rhino’s rendering screen as shown. It’s not only with this file though, every other file is the same too. Some of my friends have this problem too, but some don’t. I’m using maxwell 2.7.20 for your information.


(Brian James) #10

Can you recreate the problem with a portion of the file? Please try selecting a few objects>using Export to save them out as a separate 3dm file>Open that file and see if the problem is still present. If it is, please upload the new smaller file.


#11

test.rar (586.6 KB)

Still won’t work even with the new file (attached). I have also included a comparison image (it is in an Isometric view) which shows that it is completely off angle.

Thank for in advance


(Brian James) #12

Thanks, I see what you mean. It appears only when the target is not set to 0,0,0 .

I’ve email @jdhill separately about this thread in case the discourse mention isn’t forwarding for some reason.


#13

Looks like a precision issue. If you change the units to meters (and let Rhino scale the model), then it works fine.


#14

@jdhill

THANK YOU SO MUCH
I’m sorry for the capitals but that did it! Been having trouble with this for years and I never knew the reason because I always preferred units in centimeters. Never thought it could cause this much trouble. Thank you so much!! I can now do work without frustration!!