Add Direct Shape suddenly doesnt add any geometry

Hi all,
I’ve worked with a script to draw some geometry in Revit.
It’s worked fine for several weeks but now, no geometry is pushed to Revit when i enable the AddDirectShape.Geometry component.

I do see the preview correctly in revit, but no geometry is transferred. This same script worked a week or two ago.

Any clues?


I tested it here and works.
Maybe you are baking in a category that is currently not visible?

Hi Kike,

Thanks for the quick reply.
I’m having issues where it doesnt work if I add a new AddByGeometry component to the frame.
However if i use existing components in my script and change name/geometry etc then it works. but freshly added ones don’t!

Geometry/name/category/material is the same. So there is some kind of funky stuff going on.

This is a script that worked well before and changing input geometry/categories/name doesnt fix it.

Another thing - How do you update it? I see posts on the forum where you guys update something and ask people to update. However at these dates, it shows no updates available for me. Both in Rhino->help->update and in revit->rhinoinside->help->update (which leads to an empty github page)




Thanks for pointing out the fact that Check for update goes to an empty page. Now is fixed.
Instead of that page this other should open.

Could you please update and tell us if the last version fixes your problem?

I updated and I still have issues.

It seems that some of my addbydirectgeometry components work and some dont. If i drag a new one in from my top-menu then it doesnt work, but some of the existing ones on my canvas work. very weird behavior.


Does the component report any warning or error in the top right corner balloon like that?

Could you please check none of the below things is true?

  1. The category where you are adding geometry is not visible. You can change it from here.
  2. Same for per view overrides.
  3. The geometry you are trying to add in Revit is too small (less than one mm.). Please check your Rhino document units and Revit units.
  4. Geometry is not valid for some reason, you can bake it in Rhino and run _SelBadObjects.
  5. The geometry you added is not in the viewport, you can use Highlight to look for it.

It would be helpful if you try those two things on your side.

  1. In the Grasshopper document that you have now, there are some old AddDirectShape.ByGeometry that work. What happens if you Copy and Paste those components? Do the duplicates still work?
  2. In the same Grasshopper document, add a new AddDirectShape.ByGeometry and save this document, open it again. What happens?

If after saving, you have a Grasshopper document that contains a component that fails, it would be nice if you can share it. Something simple like this that fails would be helpful.

Hi Kike,

Sorry for late response. I think its a revit restriction when collaborating in a file. Sometimes my script works just after synchronizing Revit.

A workaround is that you enable “editable” in worksets, then the script works. But this means that noone else can work in that workset in the meanwhile(!!!). My workaround was to create an extra workset for my geometry (skylights) so it didnt ruin the fun for everyone else.

As far as I know then you borrow an element when you click it, but if you check editable on a workset then you borrow the entire workset.

It would be great if this workflow would work without checking out the worksets beforehand. Also, if you can assign worksets as a parameter when you “bake” geometry into revit.

Its nice that the workflow delete previous objects and overwrite with new inputs, but it doesnt pick up old objects from another session (like closing down rhino/revit and working on the files tomorrow). It would be nice if the component could pick up the old objects and overwrite them.