Add component (Location) problem

Dear guys,
I have updated today Rhino Inside from v1.13.8494.18380 to the v1.13.8510.35816.

Add component (Location) is always placing the family in horizontal.

It was working perfectly till yesterday.
I open the same file, but is not working as expected.

Revit 2023.1

I have installed the last Daily build version, but the problem is the same.

Is there some manner to revert to installation to v1.13.8494.18380 in the meantime? I cannot find it on the website.

Thanks in advance

1 Like

Hi Jelis, can you post a bigger screenshot (where the location is coming from) or the gh file? Is the family work plane based?

Thanks.

Not sure if this is the version or a different one, but in the new version of RiR, there is a new component called Add Component (Workplane) different fron the Add Component (Location), maybe that is what’s causing the issue

1 Like

Many Thanks.
Definitely! I didn’t realised, now Add Component (Location) is just working with level-based families, for plane-based families Add Component (Workplane) will do the trick.

It’s working as expected now.

Cheers.

Hi Mohamed,
I solved the same problem as stated. But after the new update, I can’t release element. I can release elements when using “add component (location)”. This issue occurs when using “Add component (work plane)”. Do you have any information on this?

I tried it with latest public release and having the same issue actually, after releasing the elements they still get deleted after disconnecting the wires from the node.

So looping in @kike @Japhy to check

Isn’t there anymore the possibility of placing a family according to a plane without a plane-base family, as before?
It’s hard to manage now already placed family instances (just level-based families can be rotated freely).
It was super handy with older RiR versions! Any possibility of coming back to just the older add component (by location)?

1 Like

You can still provide a rotated Rhino/GH plane for the Add Component (Location) and it will work as normal for non-workplane based families…

You will only face issues if you try placing a workplane based family using the Add Component (Location). And you will also get a warning to remind you if you in this case.

Unless this problem is solved, the use of components becomes inefficient. Please assist on this issue.

These components are different to allow access to the change workplane workflows. As requested here…

Hi Japhy,
My problem is that when I use the workplane component I can’t release the elements.

@Japhy regarding the above, I think it’s missed because the topic is solved, currently we are not able to release elements as mentioned above… they show that they are release and get unpinned but if you delete the node in GH it still remembers the elements created and deletes them.

1 Like

Hi @sahi,

This is fixed in the current daily build and will be released soon on the Release candidate as well.

It was not a problem on element tracking itself but a consequence of placing families on dedicated work planes, when you release the family this component was not smart enough to also release the Work-plane. Now both are released no matter were you release from the ‘Component’ output or the ‘Work-Plane’ one.

3 Likes