Accurate Pipe Dimensions in MultiPipe


I am trying to sue multipipe to make a node of pipes, and i need a specific pipe dimension. I had the node made with traditional pipes, but when i converted this to multipipe, the diameter of the pipes is a bit smaller. Why is this? how can i change this?

i inputted the desired radius as nodesize and strutsize is set to 1 so i was hoping it would be the correct one. Thanks in advance!

Hi Pablo,

The sections along the internal pipe segments will have the input StrutSize as their maximum radius.

(circle radius 1 shown in red, MultiPipe SubD section in blue)

A subd cannot exactly represent a circle, because the vertices do not have weights like NURBS do, so the minimum radius is about 3% smaller for a 4 sided pipe.
It is planned for a future release to also include an option to use more sides around the pipes, allowing it to approximate a true circle more closely.

However, I also see now a separate issue that in the Grasshopper component the naked ends (i.e. the points with only one connected curve) still use the radius as the control cage dimension directly instead of being adjusting like points around the internal sections are - this was an oversight and will be fixed for the next version. Thanks for making us aware of this.

In the meantime, a potential workaround if you need more accurate radius control at the naked ends would be to add an extra curve segment at these ends then delete the last ring of faces from the output, or alternatively to use the definition I posted here which subdivides the cage once and fits the ends to a circle:

Oh thank you, i understand now. Thanks for your help!