7.17.22102.05001/7.18.22102.09001 Rhino Plugin Scheme Not Working

We are having difficulty with Rhino SR17 and SR18 loading our plugin and our skin.

The /scheme=schemename is completely ignored in SR17 and SR18. Using these installs:


When attempting to load our plugin which references RhinoCommon SR16 with either of those Rhino versions installed, it simply does nothing.

When launching with the Scheme it doesn’t ever load our skin.dll file.

Uninstalling Rhino and reinstalling Rhino from rhino_en-us_7.16.22067.13001.exe fixes this issue.

I even tried referencing RhinoCommon SR17 (latest Stable), but it still won’t work in SR17 or SR18.

We tried this on 2 different Windows 11 PCs, both had the same issue.

@stevebaer @dale Any ideas on what is causing this? Are there any issues with these builds and Rhino Schemes? Or am I really the only one seeing this (always possible, :wink: )

Please ignore this message. This was an issue with my assembly missing a needed .dll. However the exception through me a bit, and it was weird that sr16 allowed it to work, while sr17/18 didn’t.

But I solved the issue by using Costura.Fody/Fody to embed all of the referenced assemblies into the one .rhs file. Then everything worked fine.