Unable to load .rhp- common causes

Hi All,

Seems to be a popular issue that is usually fixed by deleting previous installs from either
C:\Users\user.name\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Marmot (b9b3c836-5b53-4f93-b359-e64bdf2a159b)\6.0.0.0 or C:\Program Files\Rhino 6\Plug-ins.

However in this case I am definitely removing previous installs and coming across the same issue.
Any other common causes?

To be clear I am installing it using a clickable RHI file made of a .rhp and .rui. It is working on most all machines I have tested it on, only on this one machine is it telling me it wont load. Any thoughts?

(Screenshot is from someone else’s previous post, but just for context).

Hi @marcotjuliani,

The primary reason for this is that the PlugIn.OnLoad override either throws an exception or returns something other than LoadReturnCode.Success. There maybe other reasons too.

– Dale

Hi @dale,
How would i go about id collisions in Registry Key Editor? Is there a known way to figure out where Rhino might be looking for the plugin elsewhere? If so would be great to know where so that can be deleted.

Thanks,
M

FWIW the error dialog you show in your screenshot is not about a plug-in ID collision.

Check all dependencies for the plug-in are available (runtime libraries, other dlls), and possibly license.

@nathanletwory Ok good to know. I have little to no other dependencies outside of Rhinocommon for this particular app, so not sure what I should be looking for in terms of missing dependencies.

In order to temporarily circumvent and use the plugin we dragged and dropped the .rhp into the Rhino window. This works for that particular session of Rhino, but we found that with that approach you have to drag + drop every time you open Rhino… Again only on this one machine… Is that helpful in diagnosing the problem?

Cheers,
M