3DConnection Space Navigator suddenly won't work


#1

Rhino 5.3.1 AND Rhino WIP 5.4. MacOS Sierra 10.12.3

I’ve not had a problem and I use Rhino with the SN almost every day. But I had not since last Thursday. Yesterday I attempted to do some work and the SN was not working. I went to the SN utilities and the demo was not working either. I rebooted and tested in the utilities. It worked. I also notices the SN works to scroll windows and zoom (like in Safari) as normal. I launched Rhino and the navigator doesn’t work AND the utilities demo no longer works but window scrolling and zooming in safari does work.

I reinstalled the SN drivers (the latest 10.4.3.r2507 which is what I was using before). Same behavior - works outside Rhino, not in Rhino and SN demo stops working. I’ve tested and checked this multiple times and it is 100% repeatable. I don’t know that anything on my system changed since Thursday. No help or info on the 3DConnexion forum but this really seems to be a Rhino thing since the SN works until I launch it.

Any ideas or suggestions?


#2

Man, this had been a recent issue for me as well.
I’m on windows 10. Latest firmware. Reverted to previous firmware hoping that would help. no dice. It’s not a Rhino issue I don’t think, as it was happening with the 3DConnexion software, AutoCAD, etc for me. It was and has been really glitchy, sporadic, basically unusable. The only way it was somewhat working what when I was plugged in via USB cable (I have SN wireless) seemed to help a little bit, but still nowhere near how it should function.

I’m not sure what has changed, but if I figure it out, I’ll let you know! Hope you will do that same :slight_smile:


#3

Of course I’ll do the same. My SpaceNavigator is 3 years old and USB. It has been working great all this time until now. It seems to work in other apps but I don’t think I have another CAD app to test with.


#4

Use Space Mouse Pro but I tried for you the “old” SpaceNavigator ". It is operating normally. Rhino 5.3.1, Rhino WIP 5.4. MacOS Sierra 10.12.3. Driver 10.4.3.
Maybe you can install Blender and try the SpaceNavigator.


#5

I installed Blender and nothing happens with the SN. Do I need to activate or configure it in blender? I couldn’t find settings to do so.

It’s also odd that the SN works to scroll browser windows and I can turn the LED on and off from the 3DConnexion control panel.

This is really hampering my work. Are there other 3d navigation input devices out there that work? Although I haven’t had any problems in the past, I did recently try to use Moments of Inspiration and it has a problem with the updated SN driver. I don’t think this is related since the MoI issue has been around for a year. But, another 3D mouse option might make sense.


#6

Unfortunately I did not install blender and remembered that worked with the SpaceNavigator. Perhaps you could create a new user on the Sierra and try


#7

Ok, I have VMWare Fusion with Windows 10 running on this Mac. I can use the SN perfectly in BobCAD on Windows 10 in the VM. So that tells me the SN is itself fine and that it is either an OS, Driver or Rhino issue. I have not updated Rhino and it was working fine before so likely not Rhino. I hadn’t updated the driver prior to today (reinstall) so that’s not an issue and as far as I know I haven’t updated OSX in the last week. I’m left scratching my head on this one.


#8

Well, a few OSX updates were made the last few days as shown in system info Installation log:

Remote Desktop Client Update
XProtectPlistConfigData
Chinese Word List Update

All on 2/23.Coincidence?


#9

I’ve contacted 3Dconnexion for help but I’ve learned a few more odd things…

If I reboot and launch the demo app, I can actually use the SN but after 10-15 seconds it stops working. I have to reboot and do this again. If I reboot and wait 15 seconds or so it won’t work. So something is going on that is causing this. There is nothing obvious in any of the system logs. I also see the SN in the System Information USB listing. Am I the only one experiencing issues?


#10

Got word back from 3DConnexion - they do not support their products on Rhino Mac. Nice to know that I have been successfully using SN and Rhino Mac for at least 3 years without a problem. Guess I was living on borrowed time.


#11

Well, it turns out that I have 3 other “supported” OSX apps - Photoshop, Google Earth and Fusion 360 - and the SN does not work on any of them now either. I can’t correlate when they stopped working as precisely as Rhino because I don’t use them daily like I use Rhino. But I did use Google Earth and Photoshop with the SN in the previous week.


#12

I confirm to you that I too long ago the assistance 3dconnexion (Italy) said he does not support Mac Rhino but only Windows (but Rhino mac supports 3Dconnexion …). I confirm you that on my iMac the SpaceNavigator with Rhino operating normally (and it is curious that I never got it to work with Google Heart). An important thing to check is that there is only one driver installed on your Mac.
The best thing at this point is the SpaceNavigator try on another Mac (perhaps by installing the trial version of Rhino). Good luck.

Simon


#13

I installed the driver on my MacBook and Rhino WIP and guess what, it works perfectly as I would have predicted. This mac is running el capitan 10.11.6 - it is too old to upgrade to sierra.

So this proves that it is an OSX problem. Its the same driver and Rhino version.


#14

You could try installing an older driver 3dconnexion (by uninstalling the current one)

http://www.3dconnexion.com/service/archived-drivers.html


#15

Yes, I’ve tried that. No luck.


#16

Well, the plot thickens…

I’ve discovered that the SN does work after a reboot but only until you swap windows to Finder or another application. So, if I’m in the demo app, I can control the cube but if I select another app, the SN stops working for all apps. I thought it was a time based thing but it turns out to be a mouse focus issue.


#17

Still no joy and the support folks at 3dconnexion have been looking into it.