3080 Graphics card not recognized? Can only select CPU

As the title notes… Rhino may not be seeing my 3080. Not sure what to do…

thanks

Hi @Turner
Start by opening Rhino and run the SystemInfo command, then copy/paste the resulting text in a post here - that might give people a clue about what’s going on.
HTH, Jakob

Hi Jakob-

Thanks. Here’s the system info & what I see when I select the CUDA tab.


Rhino 7 SR15 2022-2-8 (Rhino 7, 7.15.22039.13001, Git hash:master @ 2833e18992fc4b5cf99bb29c4d8e8add4f02074d)
License type: Commercial, build 2022-02-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3080 (NVidia) Memory: 10GB, Driver date: 9-13-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.12
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-13-2021
Driver Version: 30.0.14.7212
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 10 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 4.27.2.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”


no-cuda

Assigned to Windows Hardware category.

1 Like

Hi @Turner
Start by updating your driver - that’s the most likely reason, especially if it’s more than a few months old. Keeping both Windows and Nvidia drivers updated are key to keeping Rhino happy; especially if Windows auto-updates, as those updates have a tendency to break things :grimacing:
-Jakob

1 Like

Will do.

Generally, when things are working ok, I don’t like updating drivers!

I’ll try it out here, though. Should I see it show up as a CUDA render device after updating?

thanks

If not, it’s one for the bigger brains - @nathanletwory :grinning:

1 Like

when you update, do a clean install by choosing the custom install option then checking the “clean install” check box- leave everything else as default.

( I recommend doing this for all nvidia driver installs)

then I personally always set my nvidia control panel as shown-

@jeff may call me out as this being nonsense, (and thanks in advance for the lesson if so) but it’s what I always use with good result.

1 Like

Hi Kyle - thanks - just installed without doing this, & it still doesn’t show up. I’ll see if I can reinstall as you recommend.


Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3080 (NVidia) Memory: 10GB, Driver date: 1-28-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.65
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-28-2022
Driver Version: 30.0.15.1165
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 10 GB

Still nothing showing under CUDA after trying clean install per @theoutside … going to try another restart & see what happens.

Hi @Turner
You could try and disable the Datasmith plugin from the pluginmanager and restart Rhino. Sometimes plugins interfere in the weirdest ways!
-Jakob

1 Like

Uh… ok - been using that pretty heavily this morning. :frowning: Not sure that it would affect a display driver, but I’ll try it just to see.

Me neither, but sometimes weird things happen inside computers :laughing:

1 Like

if you go to tools>options>view>open gl

does your card show up there?

Any chance your renderer is not set to rhino render?

render>current renderer> rhino render

1 Like

Try running the command RhinoCyclesEnableGpu. It may be that during one start of Rhino in the past initializing of CUDA devices failed. This then was captured during initialization and GPUs were disabled to ensure Rhino keeps on starting.

I probably should show somewhere in that device selection GUI that this has happened.

addendum: RH-67521 Notify user in Device Selection GUI that GPUs have been disabled

1 Like

Hi Kyle - here’s the card; I am set to Rhino Render.

appearance-settings

Hey Nathan - this worked.

2 Likes

Thanks for the quick reply!

2 Likes

RH-67521 is fixed in Rhino 7 Service Release 17 Release Candidate

1 Like