1. WbProcessingException: Two consecutive edges

weaverbird

#1

I have the same problem, over and over again… I am using Millipede and Cocoon Marching Cubes.

I tried _AlignMeshVertices and _UnifyMeshNormals, as well es Combine&Clean and Mwesh WeldVertices. MeshRepair doesnt have any effect.

Actually I managed to have some results with AlignVertices Component, but it take quite long and assume for bigger meshes the render time scales linearly or worse.

I would appreciate swift guesses over solutions - need a fix urgently.

Also any suggestions on how to create faster mesh (marching cubes or else from line geometry) that have more equally sized faces would be as well highly appreciated.

Many Thanks,
Solomon

I replied to this post in the old forum, but as noone seems to be active, i recreated the request here. (http://www.grasshopper3d.com/forum/topics/1-wbprocessingexception-two-consecutive-edges?page=1&commentId=2985220%3AComment%3A1911010&x=1#2985220Comment1911010)

01 without AlignVertices

02 with AlignVertices

03 the wanted result after smoothing


(Michael Pryor) #2

Use weld then cull unused vertices from mesh edit before the weaverbird component that is giving that error usually does the trick.

For straight lines you might try exoskeleton.


(Giulio Piacentino) #3

Just Weld with a vertex tolerance of 0.0001 should do the trick in this case.


#4

Unfortunately your suggestions dont work. Any other ideas?

Also, could you help with smoothing the mesh itself? I tried MeshMachine and ReMesh, but the results dont have much effect. Again, when the meshes get bigger it computes too long.

Exosceleton works for simple geometries. It fails often from the start, because my line netowkr typology is too complex. The biggest problem are the nodes. Sometime of them are succesful and some fail. Cant recognize any pattern.


(Michael Pryor) #5

Any luck with cull unused verts after the weld (and maybe setting weld to .01)? I know @piac says it is not necessary here but I find it to solve this issue often for me (maybe I just have some dumb luck in my cases :slight_smile: )


#6

Thanks for the swift reply again. Do you mean a different Weld Component than I used? The input is an angle and it doesnt work.

I also updated: http://www.food4rhino.com/app/meshedit


(Giulio Piacentino) #7

Do you see the orange component (in the first picture)? What is the balloon saying? (if you do not see it, Display -> Canvas widgets -> Message Balloons in Grasshopper).

There are other types of issues that a welding component cannot fix (stacked copied faces are one of them). I would suggest running the mesh through Rhino’s _MeshRepair, and see what it says.

Thanks,

Giulio


Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com


(Michael Pryor) #8

Do you mean a different Weld Component than I used

Nope, I said Cull Unused Vertices After Weld with using the mesh edits weld which is a distance tolerance, not grasshoppers which uses an angle, and set that distance tolerance (t) to .01 :smiley:
Capture

But also check the mesh in _MeshRepair as Giulio suggests.


#9

Sorry, but which picture? I guess you mean this:

and it says in the Ballon “1. welding mesh with this settings was not successful !!! …output of the original mesh”.

I did MeshRepair, but no success.


#10

I used that, but no success. I checked again with MeshRepair, but still nothing happening at all. Other meshes I could repair btw.


Ballon Message: 1. welding mesh with this settings was not successful !!! …output of the original mesh


(Giulio Piacentino) #11

Wow. This is really really a bad mesh. Is there any way you could send it to me?

Thanks,

Giulio


Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com


#12

Ya, but surprisingly the other meshes are perfect. Here the bad mesh file: https://file.io/25TN5H


(Giulio Piacentino) #13

“page not found”

Well, if that one is the only wrong mesh, you might just use the others?


#14

Pardon me… the link will work now.

One of the Mesh Cleaning Methods works. But it takes too long. If yours or Michaels ideas can fix it, I would save a substantial amount of time and lower the risk of something jacking up over night.

In the end I want to create a biomorphic “thickened” geometry around a complex line network. If you or anyone has suggestions on how to do this more elegantly, that would be great.

So far, Coccon and Millipede works for me – Millipede fails more. I need to look into MeshLab, MCE https://sourceforge.net/projects/mce-marching-cube-eld/, Autodesk Netfabb, Digital Substance ISO Surfacing, but don’t find the time at this moment and probably wont at all. Unsucessful or insufficient for me was Exosceleton and Aether.

Many thanks


(Michael Pryor) #15

Honestly, if I were to do that I would just make some simple mesh pipes on the curves and take it right to ZBrush. Zbrush would figure it out in one nice clean mesh in a few seconds or so. Huge Rhino fan, but some jobs are not right for it.

http://docs.pixologic.com/user-guide/3d-modeling/modeling-basics/creating-meshes/dynamesh/
http://pixologic.com/zbrush/features/decimation/
http://docs.pixologic.com/user-guide/3d-modeling/topology/zremesher/


#16

Thanks for the suggestion. Downloading it now. I understand so far, that MeshPipes will be an input for DynaMesh and E Voila? And ZRemesher and Decimation I’d use to clean up and optimize afterwards.


(Michael Pryor) #17

Essentially yea, it will create a kind of shell mesh around those pipes. ZRemesher will make it have really good topology. Decimation master will try and reduce polygon count without loosing detail.


(Giulio Piacentino) #20

You can fix this mesh relatively quickly by following these steps:

  1. Run _AlignMeshVertices with some tolerance, 0.001 will do
  2. Run _UnifyMeshNormals. This will make the mesh look good again
  3. Open the _MeshRepair dialog. “Check mesh” -> “Repair mesh” (3 times). Each time something else is fixed.

You get a valid mesh as a result. It has some self-intersecting faces, still, but it should be fine for WB. This mesh in fact now works in Wb.

Thanks,

Giulio


Giulio Piacentino
for Robert McNeel &