Z axis snap

Snaps work well with X & Y, but not Z.
is this normal ?
(with grid snap turned off)

The grid snap works on the local construction plan XY grid in each viewport. You can use elevator mode to move in the Z direction. More on how Rhino coordinates work in the Working in 3D > Accurate modeling section of the Rhino User’s Guide http://docs.mcneel.com/rhino/6/usersguide/en-us/index.htm and in Chapter 5 Precision Modeling of the Level 1 Manual https://wiki.mcneel.com/rhino/6/trainingguides/en

I figured it is grid related. was just wondering if I missed a setting to force Z snap.
thnx @davidcockey

Hi Yelen - a partial solution, maybe - you could AddGuide in your template file(s) at Z.
Running this macro in any file would add a guide on CPlane Z:

! _AddGuide 0 0,0,1 Enter


I saw similar concerns a long time ago but still, I can’t really understand why there is no option for Z-direction snap working similarly as XY with the shift key hold. One solution to it and an extremely good idea was introducing OneView option. @yelenaye give it a try.
Anyway, I think something like Z-direction snap activated by holding a key (maybe ctrl+shift?) would be helpful.

I gave elevator mode a second try and maybe it’s better that I thought.

Elevator mode already provides a Z-direction snap, snap to the desired XY position, then hold down the Ctrl key (not the Shift key) and move to the desired Z postion. Snap does need to be turned on.

thnx guys!
@pascal that’s a neat lil’ trick ! ( which you’re full of :wink:
it’s in my template now, thnx!!