XYZ of coordinate axis is too small to see

5A732, Macbook pro with retina 2013 later.

XYZ text of coordinate axis is too small.

Yes, I am having the same problem.


Me to!

Software information

Software versions
Rhinoceros version: 5.0 WIP (5A732)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.2 (Build 14C1510)


Third party kernel extensions
com.3dconnexion.driver (10.2.1)
com.avatron.AVExVideo (1.7)
com.avatron.AVExFramebuffer (1.7)

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470S CPU @ 2.90GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 660M 512 MB
Memory: 512 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Western Digital: Elements 10A2
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple Keyboard
3Dconnexion: SpaceNavigator
Western Digital: Ext HDD 1021
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Wireless Trackpad

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.2.1 310.41.15f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: None

The world axes are programmed to be a set size in pixels and cannot be changed. I know; I already complained about it! What is even weirder is that you can change the colors of all three axes … just not the darn size.

McNeel staff: is this request noted and/or coming anytime soon?

It’s a Mac Rhino only exception tweak so it’s not something that will happen quickly.

It is the size of the XYZ characters that has clearly changed in the last version only, nothing to do with the size of the axes themselves.


A lot of OpenGL related stuff happened in the the last couple builds. Maybe @marlin sill know if this was touched.

I didn’t notice this was a Mac thread until after I posted. But, I still have the exact same problem on PC. When your resolution approaches 4K, the world axes icon – and letters – get smaller and smaller. I sometime have to rotate my view to read the characters!

The other problem is when recording and watching video tutorials. If you are watching a video at less than 100% – forget about it! The indicator turns into blurry pixel mush.

@stevebaer has a fix for this coming.

Big roger that. In fact on my display (1920x1200) it’d be nice if you had a means of increasing the size of the whole widget.

This should be fixed in the next WIP

What about us PC nerds?

We will have better ways to do this in V6, but for V5 you can add the key highlighted in this image in regedit to adjust the label size. You need to do this while Rhino is closed.

I tried this, but the X, Y, and Z letters got bigger and the three legs of the axes stayed the same size … making it harder to read.

I need either the whole thing scaled up or just the lines in the axes.

You can change the axis line lengths by adding another key to the registry


try setting that to a value of something like 50

Steve! Thank you very much. My high-resolution laptop is finally much more productive with Rhino. :+1:

FYI : I found that a label value = 24 and axes value = 72 work well.

Is there a similar file buried somewhere in the Mac build that can be edited to do the same?

There is not. We plan to unify the Mac Preferences / Windows registry settings in a future version, so that’s when this could become available.

This still isn’t fixed.
I’m having issues with the commercial version PAID.

The XYZ text is still too small on your computer? That’s concerning. From our perspective, this issue is fixed (MR-1646). Can you give more details? Screenshots and system information (Rhinoceros > About Rhinoceros > More Info… > Copy to clipboard > ) would be helpful in understanding what is going wrong.