WISH - Universal Construction plane - update view


#1

Hi,

When working with universal construction planes enabled in setting.
This works really well. However if I change view in my viewports (i.e. from left to right) the viewport is reset to world construction plane and not my current construction plane.

Is this a bug or a feature?

it would be very useful if the viewport would reflect the current construction plane.

Thanks.


(Dale Fugier) #2

I’m not sure I understand this. How can I repeat this? What commands are you using?


(Pascal Golay) #3

Hi Morten- does the setting in Options> View for ‘Named views set CPlane’ have any effect?

-Pascal


#4

Hi Dale,

You need to have Universal construction planes switched on in properties.
Then set up a new construction plane and save it to ‘named cplanes’.
When making a new cplane your viewports should automatically update to reflect the new cplane.

However. If you then in a viewport, using the drop-down menu in top left corner, select ‘set view’ and i.e. ‘left’. This will show the world view in left and not your cplane in left. This is illogical in my view.
To get the cplane in left you again have to apply your named cplane from the named cplane panel and then the viewport finally updates.

Does this make sense to you?


(Pascal Golay) #5

Hi Morten- use SetView CPlane Left. Just ‘Left’ is world left… There is a button for each Cplane ortho view in the Set View toolbar.

Does any of that help?

-Pascal


#6

I think what he is asking, correct me if I am wrong, is:

If you have the universal CPlane option set. It works fine where is sets the same cplane in each view, Until you use the view drop down menu and change the view direction like SetView -> Top then it sets the cplane in that view to the Top, and doesn’t retain the named cplane. So now not every view has the same cplane. Is there a way to change the view direction without disrupting the named cplane?


(Pascal Golay) #7

Hi Dennis, Morten - in Options > View,> Named View sets CPlane… does changing that setting help?

-Pascal


#8

My is check on, but doesn’t seem to make a difference.