[Wish] Fillet combined with FilletEdge in a single command

Many times I intend to make a fillet but it turns out I need an EdgeFillet and I in fact don’t even know if it has its own button.
Why not make these commands Fillet/FilletEdge, Chamfer/EdgeChamfer activate via a toggle inside the commands and this choice to be memorized like Solid option in OffsetSurface. (Good question is why Extrude doesn’t remember its Solid option?! :stuck_out_tongue_winking_eye: ?)

1 Like

please - No.

please keep it separated as is,

based on object-type, input and desired result:

_fillet → curves
_filletEdge → joined surfaces / polysurfaces / solids
_filletSrf → “generate the trace of a sphere rolling along to surfaces”

Maybe “fillet” should name “filletCrv” the same as “blendCrv” the difference should be more obvious than now. For the first time, I’ve thought that fillet command is old filletsrf and do exactly the same because some commands may be doubled. Maybe it`s only me.


I allways thought that fillet as well as match were inconsistencies and should be named filletcrv and matchcrv.


if you don t like the naming of commands - you can set up aliases…
matchCrv → _match
filletCrv → _fillet

I’m only saying that I was a fresh user not so long ago and that difference was odd to me. Because it should be consistent IMHO. I don`t feel pressure to change it but I think that for many green users (same as for me) it would be much simpler to remember at the beginning of the Rhino journey. Then I would remember that all “…Crv” are for curves, all “…Srf” are for surfaces, all “…Edge” is for edges, and so on…
Commands without any addition would be more intelligent and work on few types at the same moment. I write it not as an advanced user and it reflects only my personal opinion.



Exactly my feelings about this “problem”.
It is not even an annoyance for me personally, just slightly strange.
But new user might be confused by it.


If properly done a single command could do the fillet based on what is selected and not have to type in everything (different commands) but whatever… (same goes for extrude and offset, fillet, chamfer, extend, match, blend… could be made to work on all types of objects (curves, lines, surfaces, face of a polysurface, subd, face of a subd, etc.)


This is a recipe for pain. It so vastly complicates the process of selection and available command line options that you would be at our gates with a pitchfork if we combined all of these. Imagine, for instance, your run the super fillet command and you have to answer the question, every time you click on a surface edge, of whether you want to fillet the edge as a curve, or on the solid, or the two surfaces there - you’ll need to set some kind of filter or something every time, (which is already done by separating the commands), not to go mad.



Nevertheless, I think this is still a very valid point, especially for new users:

I also don’t think it would bring insurmountable pain for experienced users, except for those who are really, really set in their ways.


I would like to add that during my first contacts with Rhino I was overwhelmed with buttons that’s why I’ve started with typing commands. I like the help list of commands when I start typing in the command field. It helped me much to know what else commands I may use. After finding any strange command I checked it every time in online docs help. That’s why I`ve stated before it may be helpful for green users.


Help > Command help is very useful to anyone who just started to learn Rhino, because it updates in real-time.

1 Like

I presume you are referring to the ability of an open help window to dynamically display the help for whichever command is being used?

Too bad this feature is not available to offline V7 users since no-one at McNeel seems to think it sufficiently useful to make the help file available for download despite fruitless pleas from offline users.

Yes, I meant the same window. :slight_smile:

I honestly find this window annoying and useless. I had never used it, didn’t impact my Rhino learning at all.

To this I can only reply with: it’s your decision, If you wanna make it easier/friendlier/smarter for your customers or you wanna make it easier/friendlier for yourself…If you look at your command names you will see many inconsistencies because you separate the similarly-behaving commands into separate commands, hence also the problem in translating the commands in other languages. Food for thought!

Since you put it this way for answering a single question based on your selection. I’d rather make 2 clicks: one on the super-fillet command and one to decide which object I wanna use than to have to press 20 keys on the keyboard, thus making me let go of the mouse and the 3d mouse for that!

1 Like

I learned the majority of modeling with Rhino 2 the hard way: clicking on each icon and figuring out what’s going on on the screen. :rofl: At the time (2002) I didn’t knew English, YouTube was still non-existent, no online-tutorials nor I was able to understand Rhino’s own tutorials, so I had no other chance than clicking on random icons and observing. I had limited access to Rhino 2 only by visiting the company where my father worked at the time.
Sometimes I use “Command help” window just to find out which toolbar “hides” a specific tool icon that I want to move to my custom toolbar. :slight_smile:

This makes sense to me. I would suggest that the ideal solution would be to simultaneously have the things like that:

  • A general “Fillet” command that has an optional command prompt with plenty of options to filter out whether you want to fillet only surfaces, polysurfaces, curves, polysurface corner etc. It could be made to prioritize the options in this order if you click on a polysurface edge: “FilletEdge” > “FilletSrf” > “FilletCrv”. This would be the single command that could evoke any of the following:

  • An additional set of individual commands such like: “FilletSrf”, “FilletEdge”, “FilletCrv”, “FilletCorner” etc.

And that isn’t that hard to do, I can do this with a script but I think most users will benefit from this so why should all script the same thing instead of making it a default behavior?

1 Like

From my point of view, a “Super fillet” command could work perfectly fine on polysurface edges, non-joined surfaces, and curves that the NOT in the same place (not to mention that a filter option to priotize the type of geometry could further make the usability better). This basically covers 99% of the cases.
In the very rare exceptions where I simultaneously have polysurfaces, surfaces and curves all in the same place (with my modeling workflow this happens once a month probably), I would just click on the individual type of fillet command for that specific geometry. But in 99% of the time I would need just a single “Super fillet” command.