WIP 20171003 - Undo doesn't work?

Well, as title said - seems that Undo is not working??!!
Just opened new file, added few lines and tried Undo - saying "Nothing to Undo"
Can you repeat this, guys?

Added: I also have checked memory for Undos - everything is ok. So, smth really goes wrong then…

Seen this last night in the previous wip but I have to test the oct 3 wip more and see if it’s still there. In the previous wip undo stopped working when I assigned materials to an object, I was able to get around it by using undo selected and I noticed that the material steps were listed there and I could undo them but regular undo would not undo the steps/ materials added to an object.

I didn’t have any problems with undo in previous WIP, only in this.
Hopefully, anyone can repeat it or?

Tested a bit more.

So, Undo doesn’t work until I run a command ClearUndo.
After this Undo is working.

Any idea why this is happening?

Hi Dmitry - I have not seen this but I will test some more… Are your lines in the modeling views or a layout? Not that it should matter…


Have same problem now.
In Wireframe Viewport undo doesn’t work.
Copy and Cut is ok.

From Edit->Undo or Ctrl Z is same.

ClearUndo does seem to fix.

Hi all - I have seen this a couple of times in our internal builds since you first pointed it out - it’s on the bug tracker but no progress that I know of, so far, in tracking it down.