Rhino 8 Beta : Undo Not Working

It doesn’t always happen, but I run into this error very often.
Undo Not Working
Undo Not Working.3dm (108.1 KB)

This is a hard one, since you mention it doesn’t happen always. In the file you sent here, I cannot reproduce the issue. Does this happen to you related to sections, or in general?
Please provide the result of _SystemInfo, thanks

I do experience this too from time to time. I have no idea what triggers this… It looks like it happens with files that are open from quite some time (>2h).

I have a feeling it might have something to do with layouts or blocks

Hi. Gijs.
All of my testing was relevant to SectionTools, which was always there.
The files are all very simples. They includes some geometry, sections created through SectionTools, and a few layouts.
I run into this error 1~2 hours after opening files.
Error with Undo always comes together with error with scale setting for layout…
SystemInfo.txt (2.3 KB)

I think this is why:

License type: Corporate, build 2023-09-21

I find it incredible that you complain about software we did not provide


They managed to use the Beta with a cracked V7 license…?

1 Like

We just fixed a significant bug in Gumball relocation that caused memory corruption. It’s possible this fix also fixes the undo problem you’re seeing. A new Beta went out a few hours ago - please install it and test.

1 Like

Hi there,

I’m running into the same ‘undo’ issue. I only just started testing out Rhino 8 today, so I can’t tell you if this is going to repeat for me. However, when I first noticed it, my file had been open for a couple hours already, so before restarting Rhino I decided to check another file - it wouldn’t undo there either. I then closed all Rhino windows and reopened my file to find it working again. By the way, it says there’s nothing to undo whenever I try to use the command.

Here’s mv system info
UndoBug-SystemInfo.txt (3.2 KB)

Could it be something to do with this setting?


@devingrayart of this happens again, before closing Rhino, could you send the result of your CommandHistory?

Hey there, I was able to recreate the issue. Here’s my command history, but I don’t think it shows what triggered it.
UndoBug-CommandHistory.txt (5.0 KB)

Everything was working until I specifically changed the boundary colour of a layer’s section style. Immediately after doing that, I deleted a piece of geometry and then I could not undo it.

hi @devingrayart thanks. I just managed to get the Undo to stop working, while messing a bit with the layers styles and a clipping plane on a Rhino session that has been open for a while, after switching from Rhino to check something on Slack and coming back. I’m not sure yet what causes it but at least now we have a few pointers.
I notice there is an undo stack in UndoMultiple, but it doesn’t work.

1 Like

This seems to be fixed now with RH-78325 Layers panel not ending undo record

Awesome, nice work! That’s huge :slight_smile: