Why Loft between 2 List Items Results in a single line only?

(Attt) #1

Hello,
New to gH - Why won’t loft work for this script? I am not sure what is the problem, I have tried Fit Curve / Graft / changing my geometry shape and I don’t know what I am doing wrong.

2019-03-23.gh (39.1 KB)

0 Likes

(Michael Pryor) #2

Flatten the C input of loft.

0 Likes

(Attt) #3

I’ve done that, and it makes no difference in results

0 Likes

(Michael Pryor) #4

I see, it works fine what you have, you have the wireframe preview mode on, change to shaded gh preview.

1 Like

#5

I’ve made many objects from Loft surfaces constructed from vertically stacked closed planar cures, so I was puzzled when I could not get your file to work. It took me a while, but I found a simple fix to make it work.

If you Lock Solver, open your file, copy and paste everything into a new file, and unlock Solver, it works - at least for me. So this tells me there is something wrong with your GH file - but I have no idea what it might be. (I’m not sure the Lock/Unlock solver steps are needed, but they do speed things up.)

I tried this because I could not make a Patch or Boundary surface from your input curve. I also could not make one from an ellipse or circle I added to your file. So this told me there was something very weird going on.

I also noticed that your input curve does not seem to lie on the XY plane - at least that’s what the Planar object told me.

Maybe someone here can explain why my method works - it’s a mystery to me.

0 Likes

(Michael Pryor) #6

It is because the file is in wireframe gh preview mode. When you copy to a new file the default is shaded so it shows up, so that file needs to just be switched to shaded.
Capture

1 Like

#7

Wow - what a simple and elegant fix - thanks Michael. I guess sometimes we (or me) can’t see the forest through the trees.

0 Likes

(Attt) #8

Wow Thank you so much!!! Really appreciate it :heart:

0 Likes

(Attt) #9

Thank you for your explanation, I appreciate your time to write even though there was a simple fix. :hugs:

0 Likes