Why is moving and undoing so slow when reading in the file is fast?

Hi guys, this is driving me crazy…
(@wim, @pascal)

We often need to import large maps as PDF’s and that results in thousands of curves and small triangular hatches. Which is OK given that we can’t get another file format.

BUT we often have to move them and scale them and sometimes I do something wrong and need to undo… and then all hell breaks loose. And I don’t understand it, why is reading in the PDF so super fast, but moving that same data (rewriting within Rhino) is soooo slow??? It makes no sense to me and obviously is frustrating.

Reading in the file takes 5 seconds. Scaling that same content takes 1 minute and 50 seconds!

Note: Once the file is read in I usually block the content and then moving and scaling is fast as anything.
But then if I open the block and edit something then closing it takes a looong time again.

I understand that 11.000 hatches and 44.000 curves is a lot of data, but why can Rhino read it and generate all the data in 5 seconds? And not edit it in 10?

Hei Jørgen - if you can provide a file, I can throw it on the list so that a developer can see if there are possible optimizations somewhere.
You can upload it on https://www.rhino3d.com/upload

I’ll upload a PDF.
Import the first page and then just import it and move or scale the content.
Try making a block and move that too, and then edit the block.

and can you tell the discourse guys that links should default to new windows?
Since you want reference to the topic it would be nice if discourse stayed open :slight_smile:

(This is handy for any other links in discourse too)

1 Like

Takker, Jørgen!
I’ve played with that PDF a bit and am not seeing the slow-down that you are seeing.
I’m getting a lot of bad objects that are being created all the time but everything that I do with it completes within 5 seconds or so.
Are you doing this on Rhino 6 or 7? Could you just post the SystemInfo so that I can test with the exact same version?

Hm, strange. I have visual arq and Bella installed… I will try without them loaded!

Hi Wim, I just deactivated the TwinMotion direct link plugin and suddenly moving the PDF content went from 40 seconds to 3.

Note that this is a new file with out any twinmotion stuff going on.

Edit: (But if I drag it and then hit Ctrl-Z then it takes 40 seconds again… so apparently that’s a different thing)

Edit2: And after the undo then dragging taks a long time again… So apparently the fix wasn’t that simple.

Hei Jørgen -
I’ve worked quite a bit more with that PDF file and still can’t reproduce any slowness. Is that repeatable on a different machine there as well?

I’ve logged RH-59253 for the issue that I ran into with that file - always creating bad objects when moving the geometry.

As for this one:

For external links, you can change that behavior in your Preferences > Interface > Other settings for Discourse:

1 Like

Thanks and thanks!
I’ll investigate the pdf ans see what I find!