Why does pipe not work

Recently added a handle curve on a project to create a pipe. It worked the first time. Then I had to modify the curve. Since I cannot create the pipe no mater what option I choose.
If you need the file, please link for private download.

I select the rail curve enters the start and end diameters click enter when asked for point for next diameter. then pipe is not created. No error or warning messages. Have to assume rhino does not like something on the curve but no messages to correct.
Here are the curve properties:
**curve **

** ID: e6807595-06ed-4d8d-b8fd-99ac049f611a (11182)**
** Object name: (not named)**
** Layer name: Default**
** Render Material: **
** source = from layer**
** index = -1**
** Attribute UserData:**
** UserData ID: 563238F9-C201-411d-A7B1-13895A0317AD**
** Plug-in: Rhino**
** description: AutoPointsOn**
** saved in file: no**
** copy count: 1**
** UserData ID: 2B1A758E-7CB1-45ab-A5BF-DFCD6D3D136D**
** Plug-in: Displacement**
** description: CurvePiping object data**
** saved in file: yes**
** copy count: 56**

** Geometry:**
** Valid curve.**
** Open NURBS curve**
** start = (-85.7249,19.2593,80.5447)**
** end = (-108.522,24.9848,-187.435)**
** degree = 3**
** control points: non-rational, count=5 **
** knots: uniform (delta=1), domain = 0 to 2**
** clamped at start and end**

Any help would be appreciated. Really frustrating…

Hello - are you using the Pipe command, or the ApplyCurvePiping shaded viewport modifier? It looks like the latter. Can you please export the curve to a new file and post it here? I don’t think I need to see the entire file.


Thanks Pascal,

curve.3dm (34.3 KB)

Here is the curve.
I use the pipe command. I did at one point use the curve piping setting at one point and that works but this is not sufficient. I need to create multiple concentric pipes to represent the different layers of the shielded cable.


Hi JMarc - the one end has two stacked control points - the more curved end. That should be avoided. (Turn on CurvatureGraph to see the effect…)


Thanks… Would be easier if there was a warning on why the function is not working…