Why does my EVALUATE component show errors?

Totally follow the tutorial to create the parabola curve, but got stuck the EVALUATE component…
What is the problem here?

Hi,
Maybe you should change ‘Variable x’ to ‘x’ and ‘Variable y’ to ‘y’ …?

It is because you are using full name mode.

Thx for replying, if you mean this, it doesn’t work… Or what do you mean?

Hi - check this post for more information:

thanks for your replying, but it still doesn’t work at all…

What’s the error you’re getting? You can see it by clicking on the red balloon in the upper right corner of the eval component.

The errors show on the first pic, can you see that?

Yes I can, it doesn’t make sense that that error doesn’t go away after renaming the inputs to no longer have whitespace. So I was wondering if there’s a different error now.

It could be a windows/macOS difference, but maybe something else is going on.

i have the exact same issue, any solution?

1 Like

Rename your inputs so they don’t have spaces in them. Not Variable x but just x.

thanks David, after i toggle on/off Draw Full Names, plus whatever i did, it’s working now, seems that’s a bug obviously

Well, a bug yes, but one without an easy fix. The Draw Full Names hack overwrites the user name of the input parameters with their name, but there’s no easy way for the component to afterwards figure out whether the invalid name was set by the user or by the menu.

I logged it under RH-52826, but I don’t know if it’ll get fixed. The problem has been there for years so probably doesn’t qualify as ‘critical’ at this point.