Why does a simple shape develop measles when projected to simple planar surface?


I keep finding that my minimum control point curves which are then extruded into surfaces and made into solids, when I come to use their edges for sweeps, I am faced with a curve of measles as opposed to the few Control points that made that surface edge originally.

Looking at the original, here e.g. we have a semicircle then straight line, projected onto a sloping planar surface (line extruded straight) and behold its now got the measles.

Why is this ? If I am to use that edge along with another that wasn’t sloping, and have the same number of control points in each for a sweep or loft, if its possible to have such, why didnt ‘such’ happen in the projection ?
Looking at my profiles, which are to be trimmed at line before sweeping, I guess I will have to add more CP’s to make the simpler ones compatible, seems odd having to de-simplify them. I tried rebuildCrvNonUniform but such as frame 2 wont simplify,

It seems to be one step fwd and two backwards. what with 1. draw profile, 2. curvature graph it and tweak it, adjust one cp and it goes wrong somewhere else…3. that done then redraw it all over again with half Cosine spacing., having created the spacing template as well. and maybe find it doesnt capture the shape.

I wish to select my solids, dupedge and use edges for sweeps, instead they have too many control points. So starting out with a correct draw and just enough cp’s (or should i say cv’s…puzzled on why I see cv when to me its cp ) to create it, I am unable to use it ‘as it comes’ later on and have to spend more time redrawing carefully what was good to lessen control points.
FewCP becomes measles.3dm (31.6 KB)
Mixed CP profiles.3dm (38.5 KB)

Try extending the surface you are projecting onto so that the entire curve projects. Then use Project with Loose=Yes. The structure of the projected curve should be unchanged.

The problem with using Loose=Yes is that when projecting onto a curved surface the projected curve usually will not lie on the surface. When projecting onto a planar surface the projected curve lies on the planar surface.

Yes, exactly. Loose=Yes projects the control points of the curve to the surface. If the surface is planar, this is the equivalent of projecting the curve as well… @pascal Methinks that Rhino should be intelligent enough to detect projections to planar surfaces and automagically use “loose”…


Hi Mitch - it actually projects edit points to the surface, so it is a little closer than if control points were projected. Yep, I agree that Project should detect planar targets and loosify automatically. (In V6, Loose projecting will not require that the entire curve hit the target as in V5 - or more accurately, that all edit points hit the target - so this is more likely to actually work)




To verbiate: eg loosify :smile:clk

A loose=Yes option with the offset command would be very handy.


And with a little nouning of a previously verbed adjective, we can speak of “loosification”. Ah, the living language.