Why am I not creating planar curves/surfaces?


(Richardpowell Powell) #1

Hello everyone.

I’m pretty new to Rhino and am having trouble creating planar curves/surfaces so I can create UV surfaces, etc.

I happen to be using Gemvision Matrix but I think my problem is a very basic Rhino or Rhino settings problem.

When I create what should be a flat, planar surface, I see that there are red lines and that I cannot select the surface. I can only select either half of what should be a surface.

In my image, you can see what should be a flat surface but I cannot select the whole surface, only each half of it. And you can see small red lines inbetween. I assume this means there are hole are non planar. But I’m building this ring with the Gemvision program. So I must have a settings wrong or something deep inside Rhino?

Could anyone please tell me what I’m doing wrong?

Thanks


(Pascal Golay) #2

Hello - it’s hard to say without the file. I cannot tell what you think should be a flat surface but if it is meant to fill in the hole in the ring - looks like there might be a read circle there - select the circle and run the PlanarSrf command.

-Pascal


(Richardpowell Powell) #3

OK, thanks. I’ll try that. How do you select? do I just left click or do I need to hold control/shift click the holes?

Thank you.


(Pascal Golay) #4

Hello - click on the red circle if that is what it is, and when you get the menu asking which of the things you want, choose the curve from the list.

FYI https://www.rhino3d.com/download/rhino/5.0/Rhino5Level1Training/

-Pascal


(Richardpowell Powell) #5

Thanks, I’ll check out the training too.

I’m assuming that closing the holes won’t make it all one surface though. So I won’t be able to select it after this as one surface our create UV’s. I could group them I bet. So I still need to find out how to create one surface in the first place.

Thank you for helping me.


(Richardpowell Powell) #6

Oh my God, you know what I think it is? I think the only problem is that the “ring rail” is still there in the middle of the ring and when I try to select the surface, the ring rail is creating the warning for non planar. By deleting the ring rail the surface is behaving now.

but thanks and I’ll do the training.


#7

Richard, The next time you have a problem it is always best to upload your file. In doing this no one has to guess and you usually get an almost instant answer.

Welcome to the forum … Danny


(Richardpowell Powell) #8

Sorry, you are correct. I should have thought of that.
I’m still having trouble with it so I’m glad you asked. It’s really strange. When I watch tutorials and see people create a ring, they seem to have a solid surface.

pimmy’s channel ring flag for uv curves.3dm (1.0 MB)


#9

Hi,

All the surfaces I excpected to be planar - are planar.

Maybe you can explain your problem a bit better.


(Richardpowell Powell) #10

Hmm, Strange then. I cannot select he inner surface as one surface.

Sorry if I didn’t explain better.

When I create a ring shape which should be surfaces I can UV Create from either outside or inside surface of ring… I simply don’t get a planar inner surface. Sometimes I get an outter one. And what is really strange, is I’m using the same profile/shape that I see people getting planar for both surfaces.

Here is another idea. I am thinking of deleting the inner surface, and then running a command to build a planar surface. How do I do that, please?

I’m attaching model with the inner surface deleted. If I try to run planarsurface command, it creates a new surface in the wrong axis.
how to create one innner surface.3dm (962.3 KB)


(Pascal Golay) #12

Hello - if you are trying to create a surface between the magenta curves in your image, then Loft will do it. But if that’s it, I am confused about your referring to ‘planar surfaces’.

-Pascal


#13

Well, first if I may be picky, why are you making the shape with more points than it needs to have?
You are just making the math behind it more complex and a possible mistake more likely.

Simple solution for the middle cylindrical surface(not planar) > circle > 3 points (pick any 3 points on the ring) > extrude : done


#14

It sounds like you’re misunderstanding what a planar surface is. A planar surface is perfectly flat, like a table top. A cylinder is not planar.

The ring is “grouped” together, twice. Run “ungroup” twice and you will get all the surfaces. Now you can pick just the internal cylinder.


#15

Just saw you had posted your file. I did a quick fix I deleted your internal lines at the bottom. Then placed a line across the two circles, did a sweep one and had these results in a minute or so. Avoid getting complicated do things as simple as possible.

All my best … Danny


(Richardpowell Powell) #16

Thank you very much, I appreciate all of the help and and describing what I should do.
I obviously have a lot to learn and will process what you all have posted.

Thank you,

Rick


(Richardpowell Powell) #17

Bingo. I think this was my biggest issue. I didn’t know it was grouped and grouped twice. Ungrouping worked.


(Richardpowell Powell) #18

So I found out more information. Whenever I create a ring using the sweep commands or builders, not one ring will have both individual surfaces created. It only creates a surface either on the outside, or the inside. I think you guys are right I should just keep it simple and build the ring from scratch. It think it’s the builder that is forcing only one surface to be editable on the ring.


(Richardpowell Powell) #19

I discovered the proper work flow. After I create the ring. I explode the whole model. Then, i check if each side it’s a single surface. Sometimes they already are. If not, they are sometimes two surfaces side by side which I then run “merge surface”.

Problem is now solved.