Who has the courage to mention hundreds of new bugs?

I am old, full-time inventor and former AutoCAD and AutoLISP user. I like the Rhino program and I still use it to make drawings of my inventions, but it seems that every new update is crippling Rhino with new bugs. Some of these bugs may related to instability of Windows 10. From the programing point of view, Rhino relies on Windows 10 so heavily that it seems to be the extension of Windows 10.

After about 1000 hours of Rhino self-training (mostly watching video tutorials) I thought that I could work fast. I was wrong! It took me one hour to draw simple tube with rounded corners. I used 7 commands only: Curve, Fillet, BlendCrv, Revolve, TiltView, Render, and Distance.

I spent half an hour making one simple closed curve. I used mostly BlendCrv command. The shape of the curve shape was changing erratically for no good reason. Fillet command was displaying strange error messages. I eventually figured out that Rhino did not display the fillet due to wrong zoom ratio.

I could not deselect objects with the escape key. I reloaded Rhino. This time the escape key worked fine.

I ran “TiltView” command. Nothing happened. I tried Shift-Alt (Page-up, Page-down). Nothing happened again. I tried to find the word “TiltView” in the Rhino help file. First I typed “TiltV”. No topics found. I typed “TiltVi”. No topics found. I typed “TiltVie”. No topics found. I pasted the word “TiltView”. No response at all. I typed the word “TiltView” by hand. No response at all. I closed the Rhino help window. Opened it again, and typed the word “TiltView”. Success!

The Rhino help file has short chapter about TiltView command. It says: “Click and drag in a viewport to tilt the view.” No, you cannot. If you press any mouse button, nothing happens.

There are still hundreds of little bugs and omissions in the Rhino help file.

Next I tried to copy the word “TiltView.” into simple text editor. I got viewport image instead of the word “TiltView.” On the second try, I got the word, but with wrong font (good enough).

Revolve command worked fine, but the revolved surface did not look right - there was strange edge in the middle of the surface and I could not figure out how to remove the edge.

I ran “Render” command. Flamingo took over. The background was black. (Probably alpha channel.) I changed the background with Photoshop to white. I looked at the rendering again - the strange edge was still in the middle of the image.

I reloaded Rhino and was typing “Distance” command while the Rhino was loading. Rhino stopped working.

I imagine that someone with much less training may feel like being pounded with a sledge-hammer all day long.

I use Rhino 5.0 commercial version (2015-08-10, 64-bit), Bongo 2.0 (2014-11-14), Flamingo nXt (2014-04-22, 2014-06-06 patch fails), PowerDirector 12 Ultra, Windows 10 Pro (64-bit) operating system, ThinkPad W530 laptop computer with Intel Core i7 3920XM processor, 32GB RAM, 512GB SSD, Quadro K2000M graphics card, 15,6 inch LCD (1920x1080).

Roy Hirshkowitz fixed major bugs in Flamingo half a year ago. Scott Davidson is back in charge of Flamingo now. I am brave person, but I do not have the courage to use the latest Flamingo beta fix. Half a year ago Scott Davidson promised to make long video about reverse kinematics in Bongo - I am still waiting for the video. I always had the impression that I was the only Rhino user that was reporting the bugs. When I posted many bug reports, anonymous users gave me anonymous support, but they did not have the courage to report the bugs themselves. A few non-anonymous posters chastised my Flamingo bug report. This bug report forced Roy Hirshkowitz to fix major bugs.

If you rock the boat, the hounds will tear you to pieces. If you do not rock the boat, the hounds will kill Rhino. I know that Pascal Golay will censor this post. He is a nice guy, but he is afraid of the hounds… like everyone else… or may be not… Donald Trump is not afraid of the hounds… and I am not afraid of the hounds… I pet the hounds in spare time.

1 Like

hmm… people post bug finds here all the time.

got anything specific you want to talk about or just a general rant?

1 Like

This all sounds very odd… Maybe something wrong with your Rhino install… All of the above work fine here. So these are not “global” bugs for everyone - otherwise there would have been a LOT more noise here.

Please post the curve and the procedure you used to Revolve so that someone might be able to reproduce the “bug”… Bugs can’t be fixed if they can’t be reproduced and their source tracked down in the code.

Unable to reproduce that here.

–Mitch

[quote=“Andrew_Nowicki, post:1, topic:28690”]
Revolve command worked fine, but the revolved surface did not look right - there was strange edge in the middle of the surface and I could not figure out how to remove the edge.
[/quote]Are you doing a 360 degree revolve? Is the “strange edge” in the same location as the revolved curve? If so then it is the seam which is a standard part of any Rhino revolved object. Not a bug.

If it something different you should post an example.

Tiltview works for me as described in its Help file. Type TiltView, left click in a window and move the mouse while holding the left mouse button down. The view tilts/rotates.

I’m using Windows 10 and the latest version of Rhino and can’t reproduce any of the bugs you mention.
BlendCrv is working as expected, as does Fillet. I can’t find any of the issues you mention in TiltView either.

Drivel… Posts here are not removed unless they are found to be offensive, personally insulting, or spam.

3 Likes

Hello Andrew_Nowicki,

I’ve noticed some weird behavior from Rhino lately when it comes to mesh rendering and the viewport not updating as usual as well as some slowdown in command execution. I chalk it up to McNeel making changes for compatibility sake for newer operating systems.

This isn’t meant to give McNeel a pass, but I do realize that the current Rhino feature set is a large hodgepodge of commands, and the bugs in those commands must be prioritized. Knowing this, sometimes the answer is to add another appropriate set of tools to the toolbox. For example, it’s no secret that I bump back and forth between MoI and Rhino regularly, there are strengths with both packages that I leverage rather than banging my head against a wall using one application only. There are some great plugins for Rhino that make the product development process much easier rather than becoming frustrated with Rhino commands that provide less than ideal results.

I know that this isn’t the answer that you may want to hear, but my impression is that McNeel would have to make some drastic changes to the product to properly address the root frustration of some users and that is more than they are willing to take on at this point. The good thing is that we have options so we can pick the best points from each tool and it leaves us with a good result in the end.

My name and Donald Trump’s in the SAME paragraph!

I’m overwhelmed.

-Pascal

14 Likes

I’m looking forward to your endorsement speech.

1 Like

Congratulations Pascal. Impressive !

I have rhino installed on several machines and never had the problems you mentioned.
The way you described the “bugs” make me thinking your hard disk has something wrong… I’ve had a laptop that made me crazy for the problems it had using some programs (formatted several times with different OS but after a while the problems came out).
I’ve changed the hd and after that no more problems at all…
Hope this can help you.

Btw… it’s cool that donald trump use rhino too… :wink:

1 Like

Hi Andrew,

We have about 120 Rhino users here, and I manage them all. I’ve had no reports of the issues that you mentioned. I would tend to agree with Lucio that it might be a hardware issue.

Dan

I hope not… I would not like to have something in common with him :fearful:

I would…the money! :smile:

NURBS-flinging, curve-cleaning, proud clingers of our single spans, our fillets, and our blends, and our valid surfaces.

3 Likes

I’d build a big wall to keep the degenerate surfaces out! And make them pay for it!

They are easy to spot, you can see those collapsed points from a long way…

3 Likes

FYI : I teach 15-20 college students Rhino every year, plus many more on lynda.com. I am also running Windows 10 Pro 64-bit and have found the combination rock-solid and a joy to use. The key is to make sure you have the latest Windows updates, Rhino SR, and use quality hardware & drivers.

I have heard of a few weird bugs from people using pirated versions of Rhino, so I will assume that’s not the problem. I did experience some random lock-ups and freezes – on all software – that was the result of a flaky hard-drive. I bought a new HD and everything was swell.

Can you post a screen capture of a before and after bug? That could be helpful and interesting.

By “degenerate” do you mean an edge that has been turned into a point? Like in a threesided surface, or a sweep2 that goes to a point? If so then I use them much. Revolve and spheres wouldn’t work without them. They are bad for offsets and fillet edges though, so don’t use them too much for that, is that why you call them “degenerate”?