What happens when ViewToFile while on Raytracing

I have a viewport with raytracing (very slow…) and I decided to ViewToFile. I assumed that it would save a jpg of the current status of the viewport. It seems to hang with the blue rotating circle. It is like this for an hour now. I did it before, but I thought it had saved it and I tried to do something in rhino and it really hung and not response. Now it seems to be doing something… it almost looks like it is raytracing the view (and not the current status), which will take forever. In that case, I will have to crash it.

Any idea?

My finding: Rendering initialized separate (to file), until the number of set of max. Passes reached. (Picture)
But progress on Export is only displayed in percent…

If you have Raytraced as the active viewport and you use ViewCaptureToFile then a Raytraced session will be started from scratch if any of the settings do not agree with what you have running already in the viewport:

  1. samples reached in viewport lower than samples requested
  2. resolution different than in viewport
    1. different scale
    2. different resolution
  3. different pixel size. This one is a bit tricky, but if you have the sharpness slider under Tools > Options > Cycles on any other position than the far right doing a ViewCaptureToFile will also trigger a complete rerender since it will always render at pixel size 1, which corresponds to the sharpness slider in the position all the way to the right

If samples in the viewport is the same or higher than what you put in for ViewCaptureToFile and the resolution is the same the current status will be saved to the file instead of rerendering

Thanks @eddi
yeah, I did it without looking at the settings and my bottom right corner reads 1/1000 after 2:00 and counting…
yesterday I left it alone and went on to other stuff. It eventually saved an image but I must say that the result, for the amount of time and if indeed there were a 1000 passes, is not that incredible…
Is 30 a good number of passes?
Thanks, N

Sounds like you have a slow machine and doing a large resolution render.

With Denoiser activated is good enough to not waste energy (on old video card) and possibilty to view PBR-Material in Viewport in fast way.

To save the viewpoart AS IT IS to a file make sure that:

  • Resolution = Viewport
  • NO multiplier (multiplier =1)
  • Number of passes = 1

If number of passes = 1 your viewport will always be of a higher state than requested and thus used as is and save is done instantly. If Number of passes is higher than what you have a reached in the view then it will restart the render behind the scene and continue until desired number is reached.

Also check if rendering on the CPU is faster than on the GPU if you have an old card.
Just swap render device in the settings and do a quick test.

On this topic, I have posted the _SystemInfo on the other post.
I understand my machine is slow, but since Rhino7 it became really extremely slow. Can you check from the _SystemInfo data if that is normal?
For instance, I am trying to test the subface settings on a PBR Material, with a grid of 5×5 cubes with different lights combinations inside. I am doing a 600×400 render with 100 passes. I use the -ViewCapturetoFile to make the image, which gives me the opportunity to know the time of the rendering. This last try took 2:05 hours.
Although it takes forever, the result is pretty miserable, and I cannot see much difference between all these situations.
The alternative normal render view is very fast but totally unusable, besides the differences look a bit random.


Render View

This sounds like the problem when using shadows-only groundplane and sun or other directional light.

Either don’t use sun/directional light, or don’t use the shadows-only ground plane.

This bug is on my list to fix: RH-64526 Sun and shadows-only groundplane very slow

Taking out the ground and the sun it went from 2 hours to 3 minutes…
Thanks, N

You can use either sun or the shadows-only ground plane, but not both at the same time. You can do for instance shadows-only and skylight or point light. Or sun and ground-plane with material.

Just not both at the same time.

Is there any update on this? Shadows-only ground plane is pretty essential to our visualization workflow.

Hi Simon -

I see that item RH-64526 is not publicly visible. It’s currently on the list of things to do in Rhino 7 and “next up”:
Skjermbilde 2021-08-31 kl. 09.51.13


I have currently one other major item, and will be able to focus on this once it is resolved.