Weird shaded display in Beta 24Nov2017

I have a simple architectural massing model that looks fine in R5


When opened in R6 Beta 24 Nov 2017, the display goes all funny:


When I pan around, surfaces appear and disappear randomly.

I don’t know the history of the model. We received it in 3dm format from the architects

massing.3dm (1.8 MB)

Is this something you can look into, please.

Have a nice weekend

Not sure what’s going on with that one but here’s a quick fix: when I import that file in the current beta, all is fine. Alternatively, you can open it, just explode everything and join it up again - that will fix things.

I think I found out what’s going on here.
The Rhino file we received from the architects was modelled in mm. Our site is about 560 km away from the origin. The weird flickering display in WIP6 seems to be caused by the rendering mesh not being updated. If I Save Small and re-open (works in 5 and WIP6), the display is fine.
There was some discussion on this list that R6 should handle objects very far from 0,0 better than R5. Has some work done under the bonnet? Are these display artificacts still expected?

The file you posted is in meters and the objects are within 185 units from the world origin.
Do you have the original file in mm and a clear procedure on how to mess up the objects?

I have found the original file (a few bits are missing in the one I’m uploading):
from_IR.3dm (1.9 MB)

I tried to replicate the display artifacts in WIP6 by converting to metres, and by moving the scheme closer to 0,0. No matter what I try, I cannot get WIP6 to show the same behaviour.

I also spoke to my colleague who worked on this some 2 or so months ago. She can’t remember exactly what she did, and in what order. Sorry

1 Like