Weird colors after printing viewport

I wanted to print a viewport that I have in Ghosted mode to show a subcontractor my design for a machining quote. I wanted to do it this way so I can clearly show how various parts fit together at this point of the construction of the project. Since the parts have no materials attached to them yet I did not want to print a render because that is just all dull grey. Additionally rendering does not show parts in Ghosted mode.

The print dialog box looked like this,

so I expected that the print would look like this.

It did not. The print came out with very weird colors all over the place. I thought that the issue was with my printer at first, but when I looked at the print by “Open PDF in Preview” I saw this:

This is exactly what my first print looked like.

The only way it seems I can print my viewport as I want is by changing the viewport background color to white in Rhino Preferences, do a screen capture (that is how I got the second image above), import the file into Illustrator, size the image and then print.

I wonder if this is a bug or if I am doing something wrong.

Objects have separate “display” and “printing” colors, though I doubt that it would be the cause of the bleached colors.

If you want your print to look like the viewing window, use the “Window” option in the printing menu. “Set” to drag a window over the objects.
Your background color will disappear when you deselect it in the “Visibility” options, drop down the list under “Output and Scaling”.


My display and printing colors are identical, except white display colors, which I have changed for printing onto white paper.

I have tried all the options including the one you suggest, i.e. Window. In Visibility panel the background color is deselected by default.

All options yield the same weird pastel color results.

Not sure about this, but something to try:

Since the display is in ghosted, you are seeing the gray background through the objects, which makes them darker. However, you are printing with a white background (which you also see through the objects) so it might be the cause of the washout. If you actually check “background color” in the print dialog - so the background prints gray - do you get a closer result?

Conversely, if you put a white background in your viewport instead of gray, does it produce the same washed out look as your print?


Thanks, I’m seeing this here too and filed two reports.

The only work around I can find is to use CMD+Shift+4 to capture a screenshot of the viewport.


Yes. Not just washed out, but completely wrong. Several parts even though they obviously have only one color (red) are now teal and pink. Several colors that do not even exist in the model are introduced.

In both cases the colors of the objects are wrong and exactly the same as in my original post. The only workaround I can figure out is the one I and Brian mentioned.