"WebGL context was lost and could not be restored"

I tried to open one of my ShapeDiver scenes on new computer and realized that there is a problem with opening. After loading scene, 2 seconds later, I am getting blank screeen and message “We are sorry WebGL context was lost and could not be restored”.

It happened on some old scenes like: https://ddc-make.com/acoustic/eng/variant3.html as well new one: https://ddc-make.com/clt-c1-thermal-knauf-insulation/
I also tried to open that scenes from ShapeDiver dashboard and have same issue

I used chrome on both computers.

Also, some colleagues reported me that they get blank screen after opening it on microsoft edge.

What cause that problems?

It’s hard to tell but just to confirm, can you see models on https://app.shapediver.com/ ?

You can also check if WebGL works on your computer at this web site:


You should see a spinning box and message “Your browser supports WebGL”. Is it the case?

I can’t see my models on https://app.shapediver.com/ . Actually, I can see them for 2 seconds and than get the message “We are sorry WebGL context was lost and could not be restored”.

I tried with https://get.webgl.org/ and I can see box and message Your browser supports WebGL…

It seems that your device struggles with rendering of the models. Here are few things to try:

  • Make sure all drivers are up to date.

  • Try disabling shadows and ambient occlusion.

  • Also, set Chrome to use the dedicated graphics card:

It would help if you could share your device specification including the graphics card and links to the models you have problems with.

Thanks for reply. It seems that problem is with Graphic card I can not run Nvidia control panel nor can see it in the device manager.
I have HP Omen 17-cb0009 laptop https://www8.hp.com/h20195/v2/GetPDF.aspx/c06351830.pdf ( Nvidia RTX 2080)
Currently I am trying to figure out how to solve that- it is obviously problem outside of this forum. I tried to update BIOS, and drivers, but Nvidia is still missing.

Thanks again, after roll back and updating Nvidia drivers ShapeDiver scenes works.

What do you mean by a roll back? I am getting the same problem. Even after updating nvidia drivers

Roll back driver means to uninstall the current driver and automatically install driver again via device manager. Here you can find more details: https://www.lifewire.com/how-to-roll-back-a-driver-in-windows-2619217

Thanks, what solved it for me was downloading the drivers manually and installing them myself instead of nvidia experience, wasted good 3 hours of installing uninstalling drivers until it worked. Not a nice experience.