VS2010 problems with opening a new Grasshopper project


#1

I keep getting this message when I try to create a new Grasshopper plug-in Project in Visual Studio 2010. I’m using Win 7 64-bit. Anybody have any suggestions on how to fix this?

Thanks in advance,
Devin


(Steve Baer) #2

That looks like a bug in the project wizard. @DavidRutten, do you know how the project wizards work or was this written by Giulio?


(David Rutten) #3

They were written by Giulio and I have no idea how they work.


(Steve Baer) #4

Ok, I sent Giulio an email invitation to see if he knows what is possibly going on.


(Giulio Piacentino) #5

This is probably to be considered a bug today. The wizards probably searches for Grasshopper in places where today it is not any longer present (user-level install, Rhino 5 installer, etc). A simple fix might be to put an “if Grasshopper is not found”, and allow the wizard to continue anyways.


(Giulio Piacentino) #6

I’ve just proposed some changes to the wizards. Somebody should probably compile them and upload them… this will not fix the fact that probably Gh will not be found, but should at least diminish the amount of exceptions that are otherwise thrown in that case


(Steve Baer) #7

Thanks Giulio,
That makes sense since GH recently moved to another location on user’s computers now that it is being installed with the RHI system. I’ll have to look into recompiling these wizards; need to do it anyway to get VS2012 support. You’ll probably be getting some questions from me soon :smile:


#8

Is there a way that I can do this manually?


#9

Hi,dear david. Glad to see you here!


(Giulio Piacentino) #10

From the message box, it seems that Grasshopper cannot be found. This link shows the way Grasshopper is still searched for in your system:

At the moment, as you can see, it is only searching in LocalMachine registry keys, which was meaningful only in the past. Right now, you’d have to install versions of Grasshopper for Rhino 4 or copy things around to make this work.


Rather than doing that, I would suggest to just use the result of the wizard I just ran for you. It would be better if you’d check all folders and locations listed in

DevinProject.csproj, especially:

C:\Program Files (x86)\Rhinoceros 5.0\System\rhinocommon.dll 
C:\Program Files (x86)\Rhinoceros 4.0\Plug-ins\Grasshopper\Grasshopper.dll
C:\Program Files (x86)\Rhinoceros 4.0\Plug-ins\Grasshopper\GH_IO.dll
C:\Program Files (x86)\Rhinoceros 5.0\System\Rhino4.exe
C:\Program Files\Rhinoceros 5.0 (64-bit)\System\Rhino.exe

You can just fix these locations, if they are different on your system, with a text editor before opening the .sln file. Please check these locations for existence twice – it’s easy to miss a (x86) or anything. I do not think other changes should be necessary to compile.

I hope this helps,

Giulio


#11

Thanks Giulio,

I’ll let you know if I run into any issues, but it looks like to me on first glance that this will work just fine.

Devin