VRML 2.0 no longer importing reliably

import
unhandled
vrml

#1

Since the 6/4 update VRML files don’t import reliably, i.e. I can’t find an example that works more than partially, and most aren’t read at all. No error message, just little or nothing is imported.

A file with spheres and cylinders that worked before and fails now: foo.zip (2.6 KB)

One with a mesh: qux.zip (85.3 KB)

I use this feature heavily and am now importing using an old Rhino 5. Can this go back to how it was last week, i.e. working?

Thanks,
Bathsheba


(Tim Hemmelman) #2

I see what you mean and I understand what the problem is. Working on a fix now.

https://mcneel.myjetbrains.com/youtrack/issue/RH-46610

Tim


#3

<3 Thank you.


(Brian Gillespie) #4

RH-46610 is fixed in the latest Service Release Candidate


#5

Confirmed fixed. Thanks.


(Dan Belcher) #6

FYI: RH-46610 is also fixed in the latest Service Release


#7

This was fixed, but since the July 9 update, 6.7.18190.21071, it’s back: my examples from the first post in this thread don’t import in current Rhino.

Halp?

Thanks,
Bathsheba


#9

sob it is still not working


(Tim Hemmelman) #10

After looking at the previous fix I honestly don’t know how it worked before. I have a better fix in the works now. See https://mcneel.myjetbrains.com/youtrack/issue/RH-47341 to track progress.


(Tim Hemmelman) #11

I understand why this worked and then got broken again. I made an initial fix. I asked a senior developer why the fix I made was necessary. He showed me the error of my ways and recommended some additional changes. It was in those changes that I introduced a new, different bug. To the end user it would appear the same as the original, both caused failures but for different reasons. See notes on https://mcneel.myjetbrains.com/youtrack/issue/RH-47341 for specifics.


#12

I guess we plebes aren’t allowed to access that? I get a 404.
But thank you for working on it – I believe in you.


(Tim Hemmelman) #13

That was my fault. You have check 2 places to give everybody access and I missed one of them.


#14

Yes, now it loads. Gotta love those “how did that ever work? :thinking:” bugs.


(Brian Gillespie) #15

RH-47341 is fixed in the latest Service Release Candidate


#16

Closure! thanks much, I see it working now.