Vray for rhino 6 plugin - can't select vray from current renderer dropdown

When I try to use the vray trial inside rhino 6, I get a message in the command line “Please choose vray as your current renderer”. So I open rhino options>rendered and then try to select vray from the dropdown under “current renderer”. I do see vray there but when I click it, it just automatically reverts to “rhino render”. It doesn’t let me select it. I did also check the plugins folder and I do see vray there and it’s checked on. I tried restarting rhino but to no avail.

Running the latest rhino 6 Version 6 SR8 (6.8.18230.16521, 18-Aug-18)
Running the latest vray plugin V-Ray 3.60.03 TRIAL Official Release Jul 3, 2018

Anyone know what can I do to make it work?

Thank you.

In Rhino Options > Plug-ins, change the list filter to Plug-ins that do not ship with Rhino.
Are all the Vray related ones enabled?
Are they all loaded “yes”?
If it’s not loaded, right-mouse click and choose Load.

Do you get an error message?

Yes, one v-ray plugin is already showing as loaded. Still doesn’t work.

You’re going to need help from a Vray user or Chaosgroup directly.
It sounds like you have it loaded so there isn’t anything else I can do.

I did change your message to the Rendering > Vray category, so it will be seen by people familiar with the tool.

Good luck

Thanks. I messaged them. Fingers crossed!

In rhino main toolbar select v-ray … about …license …license server .
It will be open the Web browser . Login with your user and password . Enable license.
Make sure your license server is installed and service is running and connected with Internet.

Thanks but I think I just solved it another way. I had to open the “render” dropdown from main menu and then select vray from “current renderer”. Strange that it doesn’t work inside the options menu but does work from the main menu…

1 Like

You are welcome . So now is it working ?

Yes, its working now. But apparently there’s a bug within rhino 6 options “current renderer”.

Okay , i see if that issue in my rhino last SR .


I am having the same problem. Oddly, it was working fine yesterday before I had a whole fiasco with my AMD graphics driver update.

Now, I am unable to select V-Ray from within the Render Panel. Well, technically I can select it, but it automatically reverts to Rhino Renderer after about 1 second.

When I select V-Ray from the Render Menu, as Peter has suggested, it “sticks” and the rendering software works … SORT OF. The Current Renderer in the Panel is BLANK, and the native interface between the two software is glitchy. V-Ray materials are slow to show up when selected within Rhino, and the Sun settings are slow as well.

Like I said, completely normal 24 hours ago before updating Windows and AMD Drivers. I am using a bootcamped iMac 2016 with Windows 10.0.19041 (newest as of October 7 2020). I have the latest 20.10 AMD driver update installed.

UPDATE: I have uninstalled AMD 20.10 using their uninstaller app, and reverted all the way back to 18.40. Version 19 was also giving me trouble.

NOW EVERYTHING SEEMS TO WORK. Good luck everyone, and careful with your software updates, especially with bootcamped macs.

UPDATE 2: The problem persisted as I was trying to diagnose other errors (VRAY asset editor scaling issues). A simple restart fixed it — it may be unrelated to the AMD Drivers.