Voronoi 2D Error


I’m having a problem with the 2D Voronoi in grasshopper. The Voronoi component is creating an extra cell in some cases without a input point. Sometimes it’ll be overlapping cells, other times it will create a random cell within another. Oddly, the Voronoi 3D component seems to be working fine. does anybody know a reason for this?

I’ve attached some pictures below and a file with the data.

2D Voronoi (example 1)

3D Voronoi (example 1)

2D Voronoi (example 2)

3D Voronoi (example 2)

File : Voronoi error.gh (18.1 KB)

With a random move it seems to suppress the problem

So the problem is surely a numeric problem with “perfectly” aligned points

Maybe you have duplicate points

There is a cull duplicate before this, but even in that case there should still be a point within the ‘random’ cell I think

Thanks for this solution, seems to have fixed it. Still weird that this is an issue in the first place

Use the Bounding box as Boundary

This seems to work as well, but still doesn’t resolve the reason to why it happens

@DavidRutten is this a numerical error within the voronoi component?