Volvox E57 Loading error

Hoping @Martin Tamke will see. Been having trouble loading smaller sized E57 files into Volvox. Larger files downloaded from duraark.eu are loading fine. But any file from even the data resource under 1000mb isn’t reading. The error occurs when connecting the data path into the load E57 component. Error Message 1. Solution exception:Object reference not set to an instance of an object. This occurs also through all E57 components. If anyone else has had this error happen on smaller files what was your solution. The forum will not allow me to upload the e57 file but it was made through Autodesk ReCap/

.

@MateuszZwierzycki may have an idea?

Hi @aemach1219,

You might consider sending the developer a direct email.

– Dale

Hey,

We wrote an e57 reader ourselves, it might have some bugs still.
There are 2 ways to fix it

  1. Open and save the file using Cloud Compare before using it with Volvox.
  2. Import the cloud to Rhino using e57 import from Food4Rhino

In both cases you’ll be able to reference the Rhino point cloud in GH using the Cloud parameter.

Rhino (also) opens E57 files…

image

– Dale

Hi @MateuszZwierzycki Thanks for getting back to me.

The e57 file does import fine into Rhino and then into volvox with the help of tarsier.
Wanted to run through grasshopper as it is a 5gb point cloud, to speed up the rhino model.

I still want to try cloud compare, currently downloading then will test.

I just noticed that from trimble the point cloud is exporting as a non-gridded, or “structured” in recap terms. This is exporting just the point data and not the scan station info. I wonder if that is the reason Volvox is having problems recognizing the file.

I have trouble importing .E57 files through Volvox too. I scraped the internet to find one of the original Duraak examples (I think they’ve been taken off their original hosting) and it imported fine through Volvox. My problem .E57 file was a structured cloud produced from Leica equipment.
I wonder what it is about the file that Volvox doesn’t like. It imports fine into Rhino.

I will resave it from Cloud Compare when I get a chance and see if that works.