Visual Studio Extension Rhino7 Error?

Hi,

i had to uninstall and reinstall Rhino7, now i cannot get the Extension in Visual Studio to run.

After installing the Extension, when i want to use it to create a new project, i get this error message:

"The vstemplate file references the wizard class ‘Rhino.VisualStudio.Windows.RhinoWizard’, which does not exist in the assembly ‘Rhino.VisualStudio.Windows, Version=7.5.0.0, Culture=neutral, PublicKeyToken=null’.

Any ideas?

Ok, i could fix it (sort of), by modifying the rhino.vstemplate file.

I removed this part:

    <WizardExtension>
        <Assembly>Rhino.VisualStudio.Windows, Version=7.5.0.0, Culture=neutral, PublicKeyToken=null</Assembly>
        <FullClassName>Rhino.VisualStudio.Windows.Wizard.RhinoWizard</FullClassName>
    </WizardExtension>

That did the trick for me, the tempate works fine now. Actually i tried this on my other windows computer and it had the same issue, so it wasnt about my rhino re-install on the laptop.

Hi @tolomeo,

I’m not sure what you’ve got going on. But make sure you have the latest version of the RhinoCommon and Grasshopper templates for Rhino 7, which is 7.5.0.4. You might also make sure your Visual Studio 2019 is up-to-date (Help > Check for updates).

– Dale

Hi @dale thanks for your reply! The problem was as follows: I updated to Rhino7, so i downloaded the Rhino7 templates inside Visual Studio 2019. These were V7.3.x and didn’t update. I could fix this by installing the .NET V4.8 developer package. Then i could update the Rhino templates t0 7.10 - everything works now :slight_smile:

I have faced the same problem, your suggestion worked for me too. Thank you so much