Visual glitch in big model

Hi all!

I have a big model, it starts near the origin but it stretch to 80+ meters.
I’m working with millimeters, but converting the document to centimeters didn’t help.

visual glitch.3dm (134.5 KB) (i have hundreds of geometries, here only some…)


(see the coordinates)

Objects near the origin are fine, object “far” away have this glitch.

Do I have to live with this or there are solutions?

(I watch the details here and there but geometries are built dynamically, moving the document origin (aka moving every geometry) is not possible because it would trigger mass recompute… )

Edit:
camera direction seems to matter, sort of that. If behind the camera frustum there is an object (or the origin), the glitch occurs. With other camera directions it look ok. … maybe…

1 Like

I do not see the problem in the video of the orange showing through the green, other than occasionally a few very brief, small flashes of orange if I zoom in closely and pan and rotate quickly. Perhaps it has to do with how fast the hardware can process and display the image.
DC System Info.txt (3.0 KB)

1 Like

On a 134KB document?
I don’t think it’s a performance related…

SystemInfo

Rhino 7 SR33 2023-9-5 (Rhino 7, 7.33.23248.13001, Git hash:master @ 332dda7497b18e9e6f82f118da5cba0c448151a9)
License type: Commerciale, build 2023-09-05
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon RX 6700 XT (AMD) Memory: 12GB, Driver date: 5-23-2023 (M-D-Y). OpenGL Ver: 4.6.0 Compatibility Profile Context 23.5.2.230523
> Accelerated graphics device with 7 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 5-23-2023
Driver Version: 31.0.14057.5006
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 28351 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

1 Like

This looks very similar - though less severe - to what @Holo posted yesterday, also with meshes -

I made a bugtrack item for that one. I added your file, thanks.

-Pascal

1 Like