Viewport artifacts with vertex colors


#1

I addded a simple sphere with vertex colors (colored inside rhino, with gh c#), and the viewport flips to white after i select a surface (shade highlight on) and rotate the view.

NVIDIA Corporation
GeForce GT 650M/PCIe/SSE2
OpenGL version: 4.5.0 NVIDIA 353.24
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 6-10-2015
Driver Version: 10.18.13.5324
Total Video Memory: 1 GB

File: Untitled.3dm (347.4 KB)

I am aware that the drivers are ‘old’, but this is not by choice: As with many laptops there is a ‘supported’ nvidia driver that comes from the laptop manufacturer.
Updating to the newest drivers breaks a lot of things.

Edit:
Workaround is to set the vertex color object to another displaymode


(Pascal Golay) #2

Hello - thanks I see this here as well.
@atair - it looks like this is related to the setting for ‘Shade vertex colors’ - if that is set the brightness problem goes away, at least temporarily’

image

https://mcneel.myjetbrains.com/youtrack/issue/RH-45249

-Pascal