Very clean mesh but very highpoly - mesh outline not working on some angles


#1

Hi I’m very new to Rhino, I’m trying to import a model from Lightwave3D which is very high poly. I use obj. format for the interchange and when I have the mesh in Rhino I do a repair mesh and I get told I have a nice and clean model so no issues there. I want to extract the outline of my mesh as seen down from the top view. So I use the mesh outline command and it only works when run it from the right or back orthographic views and also seems to give me predictable results when I run it from many angles in perspective view. But when I try to do it from the top or bottom view I get nothing… not even an error message. So the only explanation I could come up with is that it’s too much information (too highpoly/to dense model) for the mesh outline command to work with. From the Top or bottom view there is a higher amount of the polygons visable than from the side views. Does this sound like a logical conclusion to you guys ?

PS. I’ve tried to run the Reduce Mesh command and shaved off 50% of the polygons, and after that I can run the mesh outline command from the top view and everything works. But if it’s possible I’d like to be able to keep the outline as accurate to the original mesh as possible. So if you can think of a workaround I’d love to hear it :slight_smile:

Regards,
Árni Berúlfur


(Wim Dekeyser) #2

This is really impossible to say without the file. You will have to either post it here or send it to tech support.


#3

Yes… that’s a good point :smile:

Here’s the file I’m importing… I pretty sure I’m not doing anything wrong at the import dialog, but who knows.


#4

Hi Arni, once you import your obj and view it in shaded mode, it appears facetted which means the edges between the mesh faces do line up but are not really connected. You may correct this using the _Weld command with an angle of 180 degree. I think the size of the object is causing commands to fail here, depending on the unitsystem. Eg. if i work in mm, your object has bounds of only 0.352, 0.144, 0.044 millimeters.

@Pascal, i´ve found some views from which _MeshOutline still fails and guess it should be flagged as a bug, the only workaround without changing the mesh is to Scale it by a factor of 100. Then _MeshOutline worked in Top and Front view.

c.


#5

hmmm weird… it didn’t do the trick for me. Perhaps it’s my machine that’s not up to it.


#6

Hi Arni, i´ve changed my message above while you wrote your answer. Please read above.

c.


#7

ok… so the solution might be in rezising the original obj model before importing… I’m going to test it


#8

Yes, first use _Weld 180 then _MeshOutline takes a while for the top view. (i´ve scaled it by factor of 100 in Rhino)

c.


#9

Have you tried to set the tolerance higher? That should give the same effect as scaling the model.


#10

This might work as well if the absolute tolerance is set to 0.0000000001 and work in millimeters in Rhino, but i´ve found it curious that there isn`t a single vertex coordinate larger than 1 in the file. Maybe the user works in meters in Lightwave3D.

c.


#11

yes I’m working in meter in LW… I’m curious where I might find the absolute tolarance settings in Rhino.

Scaling the model up before import didn’t seem to do the trick… and the same goes for welding at a higher angle tolerance than 180° (I tried 270°)


#12

hmmmm I guess I didn’t scale it up enought… I tried again scaling it up by 100 and that did it. But it take a lot of time :confused: But Thanks a lot for the help :smiley:


#13


(Pascal Golay) #14

I’ll take a look, thanks - it looks like the object should be scaled by 1000, if it opens in an mm file, right? and end up 352 mm long, @Arni_Berulfur_Jonsso, is that the designed scale?

-Pascal