V6 Unwrap multiple objects


#1

@pascal, it is great to see that change (RH-20979) but the result of multiple unwrapped objects creates overlaps in the UVEditor. Eg try this:

  1. create two boxes
  2. select both and _Unwrap (all edges picked)
  3. use _UVEditor to see the overlaps.

I was more after a result which looks like this, excuse my workaround to achieve it:

  1. create two boxes
  2. use NonmanifoldMerge to “connect” them
  3. use Unwrap (all edges picked of both boxes)
  4. No overlaps in the UVEditor

This way you could precisely texture multiple objects with a single map. I´m not shure if the current way is so useful as it gets tricky to find the uv islands which belong to each object if they overlap.

c.


(Andrew le Bihan) #2

Thanks…we’ll look into it. Can you log bugs yet?


#3

Yes, i think i can add comments on myjetbrains if it is allowed.

c.


(Andrew le Bihan) #4

Clement

OK - my understanding about external users using YouTrack is that when you find a bug with one of these items, you should create a new bug report for the problem.

You should be able to do that already.

  • Andy

#5

thanks andy, i guess you mean the “create issue” button on YouTrack?

c.


(Andrew le Bihan) #6

Yup!


(David Eränen) #7

Hi clement, thanks for the feedback.

The individual faces overlap in the UV editor since the Unwrap option TextureSpace is set to PerObject. If you change the option to Single, no faces will overlap. Perhaps this should be the default. How would you prefer it to work, clement?

Best regards,
-David


#8

Hi David, yes i think it should be used “single” as default to avoid the overlaps if multiple objects are selected. If a user really needs overlaps it could be changed from the commandline before unwrapping.

btw. great work :wink:

c.


(David Eränen) #9

“Single” has now been made the default for the TextureSpace-option when Unwrapping multiple objects.

-David


(Pascal Golay) #10

David, it looks like only single is available now- is that correct? The item is grayed out in the UI.

-Pascal


(David Eränen) #11

Hi Pascal,

I can’t reproduce this on my end. The TextureSpace option only shows up when more than one object is selected for unwrapping. Clicking on the option allows you to select Single or PerObject.

Could you send in a screen shot of the issue you’re having? And/or step by step instructions to reproduce it.

Thanks
-David


(Pascal Golay) #12

Hi David- it’s fine, I think. I’d accidentally selected objects that had only default UV mapping.

-Pascal


#13

Hello @deranen,

attached is one file where the unwrapper gives some strage result. When it asked for edges, i did not select any so it uses the naked edges of the mesh. I´m not shure why they are ignored. Maybe in V6 the commandline should offer to choose “NakedEdges” when it asks for the edges during the Unwrap command.

unwrap_error.3dm (399.8 KB)

In this example i created the edges myself by unwelding manually.

c.